Activate changes timeout (again)

Hi,

Related to my thread that i was too slow to update (blame my business who took forever to approve me bringing in third party software)

So as the original responder said, upgrading to 1.6.0p15 fixed my issue for a small slave with 300 odd hosts.

Unfortunately, the same happens for my larger slaves (900 odd hosts)

Any way yet to uplift this 110 seconds thing?

I think the runtime depends on some factors:

  • Amount of folders
  • Amount of installed MKPs
  • Installe python libraries which not in checkmk bundle
    Please check this out.

Theres 4 folders, with 950 hosts spread across.
only 3 mkps installed, not …100% sure about these optional python libraries? Could you elaborate?

Thanks Christian

Hi,
some people istalled needed libraries for there own checks with pip. This librries will found in local/lib/python/…
You have only 4 folders and no subfolders?

I only have about 2 or 3 custom checks and most of those are just for processes or logwatchs.
Just 4, no subfolders.

I have a workaround, if i turn off “service checks” on the slave, it will then push through fine and then i have to turn it back on, but thats an annoyance.

Especially as version 1.2 could do this, slowly, but well enough

Did you check the connections between the sites. You can check if the transfer with scp or something else slow. I did not know this issue in large environments.

Oh no doubt its an issue with a large amount of objects going over a slower connection.

I just need a way to uplift the timeout value.

First step is, turn off the mkp sync to this slave. There is no impact at the sync of configuration only the files @ChristianM mentioned are not synced anymore.

This looks like heavy load on the slave.

Yup it seems like heavy load to me too.
Unfortunately, i can’t do much about that - but if the timeout were slightly longer… :slight_smile:

Sorry the 110 seconds is a hardcoded timeout inside the functions between Apache and CMK.

Can’t tell by the information if it is the same.
But couple of years ago I had the issue with 2 sites giving timeouts almost all the time.
I used the solution provided on this page, use at your own risk :wink: .