Agent-receiver shows on, but no listener created

CMK version:
checkmk/check-mk-free:2.1.0p4

Hi All,

With a fresh (test) install of the docker image (for testing the new agent mechanism) I notice the following (all in the container):

# omd status lab1
agent-receiver: stopped
mkeventd:       running
liveproxyd:     stopped
mknotifyd:      running
rrdcached:      running
cmc:            running
apache:         running
dcd:            running
redis:          running
crontab:        running
-----------------------
Overall state:  partially running

however, when looking at the config ‘omd config lab1’ , basic , agent-receiver, this is enabled own port 8000.

root@8867c4b2cdc5:/# netstat -lntp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:5000            0.0.0.0:*               LISTEN      -
tcp        0      0 127.0.0.11:41551        0.0.0.0:*               LISTEN      -
tcp6       0      0 :::6556                 :::*                    LISTEN      55/xinetd

Is the ‘free’ version limited, or is there another way to enable the receiver?

OK, this is weird.

After a restart of OMD within the container, the process does start and I can communicate on port 8000.

root@ubuntu:~# cmk-agent-ctl register --hostname 192.168.1.253 --server 192.168.1.37:8000 --site lab1 --user automation --password 123bloep123
Attempting to register at 192.168.1.37:8000/lab1. Server certificate details:

PEM-encoded certificate:
-----BEGIN CERTIFICATE-----
MIIC3zCCAcegAwIBAgIUS27UBouVCjylaAQggp5CWpJJAvowDQYJKoZIhvcNAQEL
…snip…
9lj3gUHUywVNKDyVUjUMZTmBMQ==
-----END CERTIFICATE-----

Issued by:
Site ‘lab1’ local CA
Issued to:
lab1
Validity:
From Thu, 30 Jun 2022 14:36:07 +0000
To Tue, 31 Oct 3020 14:36:07 +0000

Do you want to establish this connection? [Y/n]

y
root@ubuntu:~#