Agent Updater - change port of URL

Hi,
I implemented today Automatic Agent Updates, and all hosts got registered succesfully!
However after some time, I got for all my Linux servers a warning message from “Check_MK Agent” saying that it can’t connect to the Update URL.

The Update URL is something like this “http://server.dns.local/SITE/check_mk”. And indeed that URL is incorrect, because it should be like this: “http://server.dns.local:8080/SITE/check_mk” … I run checkmk via Docker on port 8080.
However I can’t find a way to add that 8080 as port to the URL.
If I look at my rule of the Agent updater (Linux, Windows, Solaris) there is the option to configure the URL: Update server information → DNS name or IP address of update server.
The problem is that I can’t add :8080 after my server.dns.local, because checkmk then complains that “:” is not an allowed character in that field.

Any ideas?
Br, T
PS: using 2.0.0p9 (CFE)

Hi,
as a workaround you may try to change the url in the config files directly. For a final solution you should send this as bug/feature request to feedback@checkmk.com
Br Udo