All services pending state except for Check_MK and Check_MK Discovery

Checkmk Raw Edition 2.1.0p9
Running within Docker Container

I have managed to install CheckMK RAW v2.1.0p2 and added 10 hosts to test the product,
when I discover the hosts I can see a list of services I would be interested in monitoring
(for example storage, CPU, temperature, etc) so I add them.

Then I only get data from about 2 services relating to the agent,
all of the rest are in a pending state and then go stale because they don’t receive any data…

what am I missing?

Is that not supported in the raw version?

Error message:

State Service
PEND Check_MK Agent
PEND CPU load
PEND CPU utilization
PEND Disk IO SUMMARY
PEND Filesystem /
PEND Filesystem /etc/pve
PEND Filesystem /tank300
PEND Filesystem /tank300/_Backup
PEND Filesystem /tank300/_PCS
PEND Interface 02
PEND Interface 03
PEND Kernel Performance
PEND Memory
PEND Mount options of /
PEND Mount options of /etc/pve
PEND Number of threads
PEND Postfix Queue
PEND Postfix status
PEND Storage Pool tank300
PEND Systemd Service Summary
PEND Systemd Timesyncd Time
PEND TCP Connections
PEND Uptime
PEND zpool status

Hello and welcome.
maybe dumb question but did you activate your changes?
best regards,
JF

yes I did activate the changes…
As a test I tried installing Checkmk Free Edition 2.1.0p9 and I don’t have that error… Now I just have an error in the Main Dashboard that says: Under [Percentage of total service problems](http://192.168.2.14/cmk/check_mk/view.py?filled_in=filter&service_cmk_site_statistics_core_pid=1&view_name=searchsvc&_show_filter_form=0)

Traceback (most recent call last):
  File "/omd/sites/cmk/lib/python3/cmk/gui/plugins/metrics/html_render.py", line 733, in render_graph_content_html
    graph_artwork = artwork.compute_graph_artwork(
  File "/omd/sites/cmk/lib/python3/cmk/gui/plugins/metrics/artwork.py", line 116, in compute_graph_artwork
    curves = compute_graph_artwork_curves(graph_recipe, graph_data_range)
  File "/omd/sites/cmk/lib/python3/cmk/gui/plugins/metrics/artwork.py", line 261, in compute_graph_artwork_curves
    rrd_data = rrd_fetch.fetch_rrd_data_for_graph(graph_recipe, graph_data_range)

BTW I don’t know if this matters but I was testing it on Ubuntu Server 22.04.
So I’m going to try to reinstall in a VM running ubuntu server 20.04 and see if that makes a difference.

Status update…

I tested a couple of things:

  • Test 0 = I tried installing a version fo checkmk free (the trial version limited to 25 hosts in a VM)
    – Result 0 = that was working fine connecting to agents and reporting data.
    however there was an error in the dash board relating to a few python files that I saw on the checkmk forum that they will be fixing on the next release.
  • Test 1 = So then I created another VM in ubuntu 20.04 and installed checkMK raw
    – Result 1 = It worked.
  • Test 2 = I went back to my original docker instance and cleared the site (after backing up first),
    created a stack based on version 2.1.0p8
    created a site and added a host
    – Result 2 = It worked as expected and pulled data at regular intervals with no services in PEND status.
  • Test 2b = stopped the stack backed up the folder and updated to 2.1.0p9
    – Result = The previous host is still working.
  • Test 2c = Added another host to be monitored, I currently have all services on PEND status, but I’m waiting to see if they change after a while.
    It just populated…
    so…

possible conclusions:

  1. I could have missed something the first time around.
  2. starting from scratch a version 2.1.0p9 might not create the correct config or something,
    so starting the earlier one creates that config correctly
    and then 2.1.0p9 just converts it over and updates the needed settings
    ups… sorry I meant to put this in the #help-me-please channel… but I wanted to dump my progress, before I forget and move on, just in case someone runs into this