BUG: Agent Updater auf Windows startet zu früh nach Reboot

Hallo in die Runde,
seit dem Update auf die 1.6p17 habe wir massiv “Probleme” mit dem schon am 16.4. von @pitchfork erwähnten Verhalten (hier). Wird sich da wohl was tun?

getaddrinfo failed deutet auf ein DNS-Problem hin. Das Updater Plugin auf dem Host kann den DNS-Namen vom Monitoring-Server nicht auflösen.

Wenn der Windows Host neu gestartet wurde dann ist es das gleiche Problem wie schon aus dem verlinkten Post. @MarcK starten bei Euch die Windows Server jeden früh neu?

PS: ich hab mal den Titel angepasst der sagt eigentlich nix direkt zum Problem :wink:

Hi,
ja die Clients starten regelmäßig jeden Morgen neu, das sind POS-Systeme, über 200 Stück.
Ich dachte mir schon das es die Updater Sache ist. Nur komisch das es bei uns so massiv erst seit der p17 zuschlägt…

Es könnte nur sein, dass der p17 Windows Agent etwas performanter ist und schneller bereit ist nach einem Reboot. Das vor allem noch bevor das Netzwerk wieder bereit ist.
Mal sehen ob’s jemand liest - hab je extra groß “BUG” ran geschrieben @tribe29

@SergejKipnis - It would be good that the first run of the agent updater earliest 5 minutes after reboot

2 Likes

Super, dann drück ich (mir mal) die Daumen :smiley:

Es ist möglich, den Service-Startmodus als delayed einzustellen

In 2.0 Windows Agent kann dieser Modus entweder mit WATO oder in der Konfigurationsdatei eingestellt werden.
Auch 2.0 Windows Agent wird bis zu 30 Sekunden auf das Netzwerk warten.

2 Likes

Mal testen bei Gelegenheit :slight_smile: