Check_mk 2.0 - Netapp via WebAPI volume counters broken

After updating from 1.6 to 2.0.0p3, I started seeing issues when trying to collect data from my netapp appliances. After some testing, if I check the “Do not query volume performance counters” checkbox, data collection will fail. I ran cmk from the cli to see what was happening:

OMD[SITE]:~$ cmk --debug -vvII HOSTNAME
Discovering services and host labels on: HOSTNAME
HOSTNAME:
+ FETCHING DATA
  Source: SourceType.HOST/FetcherType.PROGRAM
[cpu_tracking] Start [7f0ee9b26310]
Calling: /omd/sites/SITE/share/check_mk/agents/special/agent_netapp '-u' 'USERNAME' '-s' 'PASSWORD' '--nocounters volumes' '10.91.111.190'
[ProgramFetcher] Fetch with cache settings: DefaultAgentFileCache(path=PosixPath('/omd/sites/SITE/tmp/check_mk/data_source_cache/special_netapp/HOSTNAME'), max_age=0, disabled=False, use_outdated=False, simulation=False), Cache enabled: True
Not using cache (Does not exist)
[ProgramFetcher] Execute data source
[cpu_tracking] Stop [7f0ee9b26310 - Snapshot(process=posix.times_result(user=0.0, system=0.0, children_user=0.22, children_system=0.04, elapsed=0.27000000048428774))]
Try aquire lock on /omd/sites/SITE/var/check_mk/crashes/base/20ff05f0-acf0-11eb-b2aa-90e2ba39c16c/crash.info
Got lock on /omd/sites/SITE/var/check_mk/crashes/base/20ff05f0-acf0-11eb-b2aa-90e2ba39c16c/crash.info
Releasing lock on /omd/sites/SITE/var/check_mk/crashes/base/20ff05f0-acf0-11eb-b2aa-90e2ba39c16c/crash.info
Released lock on /omd/sites/SITE/var/check_mk/crashes/base/20ff05f0-acf0-11eb-b2aa-90e2ba39c16c/crash.info
Traceback (most recent call last):
  File "/omd/sites/SITE/bin/cmk", line 92, in <module>
exit_status = modes.call(mode_name, mode_args, opts, args)
  File "/omd/sites/SITE/lib/python3/cmk/base/modes/__init__.py", line 69, in call
return handler(*handler_args)
  File "/omd/sites/SITE/lib/python3/cmk/base/modes/check_mk.py", line 1531, in mode_discover
discovery.do_discovery(
  File "/omd/sites/SITE/lib/python3/cmk/base/discovery.py", line 370, in do_discovery
fetcher_messages=list(
  File "/omd/sites/SITE/lib/python3/cmk/base/checkers/_checkers.py", line 246, in fetch_all
raw_data = source.fetch()
  File "/omd/sites/SITE/lib/python3/cmk/base/checkers/_abstract.py", line 163, in fetch
return fetcher.fetch(self.mode)
  File "/omd/sites/SITE/lib/python3/cmk/fetchers/_base.py", line 221, in fetch
return result.OK(self._fetch(mode))
  File "/omd/sites/SITE/lib/python3/cmk/fetchers/_base.py", line 250, in _fetch
raw_data = self._fetch_from_io(mode)
  File "/omd/sites/SITE/lib/python3/cmk/fetchers/program.py", line 139, in _fetch_from_io
raise MKFetcherError("Agent exited with code %d: %s" %
cmk.fetchers._base.MKFetcherError: Agent exited with code 2: usage: agent_netapp [-h] [-u USER] [-s SECRET] [--vcrtrace TRACEFILE]
                [-t TIMEOUT] [--nocounters {volumes}] [--xml] [--debug]
                [--legacy]
                host_address
agent_netapp: error: unrecognized arguments: 10.91.111.190

It appears that the single quotes around ‘–nocounters volumes’ are treating the parameter literally. I copied and pasted the command and received the same message. If I removed the quotes around ‘–nocounters volumes’, it worked as normal.

Thanks