Check_MK Agent cached data

Internally we use CheckMK Raw edition. For our hosting environment we will be using CheckMK Enterprise edition as we need some of the functions missing in the RAW edition.

I’ve noticed that the Check_MK Agent behaves differently between the versions. In raw it checks every minute, just as any other service. I can also manually reschedule the check on the service.
I can however not do this on the Enterprise edition. Here the reschedule check option is not available because the data is cached for 60M. I can’t seem to find if this is just an inherent difference in functionality between the CheckMK versions. I can’t find any rules/options to change this behavior either. When i restart the agent on the host i have the option to manually reschedule the check for a very short time, soon it switches to cached data again.

Does anyone know if it’s possible to disable caching of this service or whether this is a good idea at all?

Has anyone got an idea?
As an example for now. I’ve just installed a new agent with the Agent updater plug-in.
Because I’ve discovered the services before registering the agent updater I now see a warning.
Even though I’ve resolved the issue the warning remains for about 50-60 minutes until the cache time has expired.

I want to be able to immediately reschedule the check so the monitoring stays clean.

Hi,

I’d say this is due to the fact that in the RAW edition, the service only uses information that is created/checked on the agent site on each run. The enterprise however also sends information from the agent updater plugin, and that plugin is (by default) only executed once every 60 minutes, to reduce the load on the checkmk server (for serving the .msi/.rpm files etc).

I think you can only reduce the cache time in the rule ‘Agent updater (Linux, Windows, Solaris)’ but that of course increases the load on your checkmk server a little (depending on the number of hosts you have, it’s possibly irrelevant)

Gerd

1 Like