Check time out IPv4 address

CMK version
2.0.0p20 (CRE)
OS version:
Debian 11.03
Error message:
(Service Check Timed Out)
Output of “cmk --debug -vvn hostname”: (If it is a problem with checks or plugins)
[agent] Version: 2.0.0p20, OS: linux, execution time 131.9 sec

Hello,

I have a problem with a host that has an external FQDN and a private IP:
The private IP is configured as network address.
But since few says it seems that check_mk tries to use the external IP first.
So the check gets a timeout.
I’m not sure if this is normal and if there is some other problem, but the problem exists since a few days.
So how can I force the configured IP to be used instead of the FQDN?

Thanks

Frank

Hi,
you can setup the rule Check hosts with PING (ICMP Echo Request)

Karl

Hi,

is this not the default?
But it makes no difference.
The host it self is up

Hi Frank,

The private IP is configured as network address.
To be specific here: have you used the private IP in the following config field:

Regards,
Gerd

Hello Gerd,

yes, I used this field

can you share the output of “cmk -D <hostname_configured_in_checkmk>” for the host with the problem?

cmk -D FQDN

FQDN                                                                 
Addresses:              IP
Tags:                   [/wato/checkmk_export/:/wato/checkmk_export/], [KVM:KVM], [VM-Host:HOST], [Yes:Yes], [address_family:ip-v4-only], [agent:cmk-agent], [criticality:prod], [networking:lan], [piggyback:auto-piggyback], [site:check_mk], [snmp_ds:no-snmp]
Labels:                 [cmk/device_type:vm], [cmk/os_family:linux]
Host groups:            HostgroupNotClusterd
Contact groups:         all, netadmin, check-mk-notify
Agent mode:             Normal Checkmk agent, or special agent if configured
Type of agent:          
  Program: ssh -o StrictHostKeyChecking=no root@FQDN
  Process piggyback data from /omd/sites/check_mk/tmp/check_mk/piggyback/FQDN
Services:
  checktype            item               params                                                                                                                                                                                                                                                                                                                                                                                                   description               groups              
  -------------------- ------------------ -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- ------------------------- --------------------
  cpu_loads            None               (5.0, 10.0)                                                                                                                                                                                                                                                                                                                                                                                              CPU load                  MTR,Check_mkVersions
  kernel_util          None               {}                                                                                                                                                                                                                                                                                                                                                                                                       CPU utilization           MTR,Check_mkVersions
  diskstat             SUMMARY            {}                                                                                                                                                                                                                                                                                                                                                                                                       Disk IO SUMMARY           MTR,Check_mkVersions
  df                   /                  {'levels': (80.0, 90.0), 'magic_normsize': 20, 'levels_low': (50.0, 60.0), 'trend_range': 24, 'trend_perfdata': True, 'show_levels': 'onmagic', 'inodes_levels': (10.0, 5.0), 'show_inodes': 'onlow', 'show_reserved': False, 'include_volume_name': False}                                                                                                                                              Filesystem /              MTR,Check_mkVersions
  lnx_if               enp1s0             {'errors': {'both': ('perc', (0.01, 0.1))}, 'discovered_oper_status': ['1'], 'discovered_speed': 0}                                                                                                                                                                                                                                                                                                      Interface enp1s0          MTR,Check_mkVersions
  lnx_if               lo                 {'errors': {'both': ('perc', (0.01, 0.1))}, 'discovered_oper_status': ['1'], 'discovered_speed': 0}                                                                                                                                                                                                                                                                                                      Interface lo              MTR,Check_mkVersions
  kernel_performance   None               {}                                                                                                                                                                                                                                                                                                                                                                                                       Kernel Performance        MTR,Check_mkVersions
  mem_linux            None               {'levels_virtual': ('perc_used', (80.0, 90.0)), 'levels_total': ('perc_used', (120.0, 150.0)), 'levels_shm': ('perc_used', (20.0, 30.0)), 'levels_pagetables': ('perc_used', (8.0, 16.0)), 'levels_committed': ('perc_used', (100.0, 150.0)), 'levels_commitlimit': ('perc_free', (20.0, 10.0)), 'levels_vmalloc': ('abs_free', (52428800, 31457280)), 'levels_hardwarecorrupted': ('abs_used', (1, 1))} Memory                    MTR,Check_mkVersions
  mounts               /                  ['errors=remount-ro', 'relatime', 'rw']                                                                                                                                                                                                                                                                                                                                                                  Mount options of /        MTR,Check_mkVersions
  mtr                  endpoint.sysgo.com {'pl': (12, 25), 'rta': (150, 250), 'rtstddev': (150, 250)}                                                                                                                                                                                                                                                                                                                                              Mtr to endpoint.sysgo.com MTR,Check_mkVersions
  cpu_threads          None               {'levels': ('levels', (2000, 4000))}                                                                                                                                                                                                                                                                                                                                                                     Number of threads         MTR,Check_mkVersions
  postfix_mailq                           {'deferred': (10, 20), 'active': (200, 300)}                                                                                                                                                                                                                                                                                                                                                             Postfix Queue             MTR,Check_mkVersions
  postfix_mailq_status                    {}                                                                                                                                                                                                                                                                                                                                                                                                       Postfix status            MTR,Check_mkVersions
  tcp_conn_stats       None               {}                                                                                                                                                                                                                                                                                                                                                                                                       TCP Connections           MTR,Check_mkVersions
  uptime               None               {}                                                                                                                                                                                                                                                                                                                                                                                                       Uptime                    MTR,Check_mkVersions here

If i put the internal IP in the /etc/hosts, it works like a charme

Hi,
you use the Individual program call instead of agent access rule. Can you show the configuration of this rule?

Karl

ssh -o StrictHostKeyChecking=no root@$HOSTNAME$

But, this works on all other servers and worked in the past also for this host

Hi,
have you tried

ssh -o StrictHostKeyChecking=no root@$HOSTADDRESS$

?

Karl

1 Like

Thank’s.
It works now, why ever is after years become a problem

If you haven’t changed the rule in checkmk, then I’d say the DNS server you are using started replying with the external IP instead of an internal IP OR your checkmk server was previously able to reach the external IP. But given the rule config, I’m pretty certain nothing changed within checkmk to explain why this worked before and didn’t today.

1 Like