CheckMK 1.6 on Rock PI 4 under Debian buster

Hello together,
i want to use CheckMK 1.6 under my Rock PI4 (armhf) and I want to know, if there anybody with the same problem /issue?

I´ve found now a version for “armhf” - processor, but I´ve got the same Error-Message:

gdebi /Zhexue-Cloud/project/check-mk-raw-1.6.0p9_0.buster_armhf.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Traceback (most recent call last):
File “/usr/bin/gdebi”, line 86, in
if not debi.open(args[0]):
File “/usr/share/gdebi/GDebi/GDebiCli.py”, line 73, in open
self._deb = DebPackage(file, self._cache)
File “/usr/share/gdebi/GDebi/DebPackage.py”, line 31, in init
super(DebPackage, self).init(cache=cache, filename=filename)
File “/usr/lib/python3/dist-packages/apt/debfile.py”, line 77, in init
self.open(filename)
File “/usr/lib/python3/dist-packages/apt/debfile.py”, line 88, in open
control = self._debfile.control.extractdata(“control”)
LookupError: There is no member named 'control

Try with

dpkg -i /Zhexue-Cloud/project/check-mk-raw-1.6.0p9_0.buster_armhf.deb
apt-get -f install

Thank you,
i will check that and give you a feedback…
But one more question before I try this.

Is it true, that the software were installed on /opt/omd - directory?
It was helpful for me, because I must check the space on this machine…

Best regards

Matthias

So, I have try that, but it doesn’t work.
Because the script /package doesn’t find some packages :frowning:

Here a small snapshot:
check-mk-raw-1.6.0p9 depends on libpango1.0-0; however:
Package libpango1.0-0 is not installed.
check-mk-raw-1.6.0p9 depends on rpm; however:
Package rpm is not installed.
check-mk-raw-1.6.0p9 depends on php; however:
Package php is not installed.
check-mk-raw-1.6.0p9 depends on php-cgi; however:
Package php-cgi is not installed.
check-mk-raw-1.6.0p9 depends on php-cli; however:
Package php-cli is not installed.
check-mk-raw-1.6.0p9 depends on php-gd; however:
Package php-gd is not installed.
check-mk-raw-1.6.0p9 depends on php-sqlite3; however:
Package php-sqlite3 is not installed.
check-mk-raw-1.6.0p9 depends on php-pear; however:
Package php-pear is not installed.
check-mk-raw-1.6.0p9 depends on rsync; however:
Package rsync is not installed.
check-mk-raw-1.6.0p9 depends on smbclient; however:
Package smbclient is not installed.
check-mk-raw-1.6.0p9 depends on rpcbind; however:
Package rpcbind is not installed.
check-mk-raw-1.6.0p9 depends on lcab; however:
Package lcab is not installed.
check-mk-raw-1.6.0p9 depends on xinetd; however:
Package xinetd is not installed.
check-mk-raw-1.6.0p9 depends on libfreeradius3; however:
Package libfreeradius3 is not installed.
check-mk-raw-1.6.0p9 depends on libpcap0.8; however:
Package libpcap0.8 is not installed.
check-mk-raw-1.6.0p9 depends on libgsf-1-114; however:
Package libgsf-1-114 is not installed.
check-mk-raw-1.6.0p9 depends on poppler-utils; however:
Package poppler-utils is not installed.
check-mk-raw-1.6.0p9 depends on libpq5; however:
Package libpq5 is not installed.

So, i don´t know, which modules /software CHECK-MK need to work.
I can’t find any informations for that :frowning:

Best regards

Matthias

As it says: “… depends on XXX” -> you need to install package XXX

But “apt-get -f install” should fix that automatically for you by pulling in all the missing dependencies, provided your APT sources are working. Plain Debian 10 Buster from the official repositories, right?

Perhaps you need to run “apt update” first.
And try “apt install /path/to/cmk-package.deb” instead of “dpkg -i …”

Hello Martin,
thank you very much for your help.
BUT!!! I think I want to do that with the SOURCE - Code Version…
So, I can build this new and see, what kind of problems that I´ve got.

Can you tell me please, which software - module I need additional to CheckMK?
Best regards

Matthias