Checkmk is not updating pnp4nagios/service graphs

Hi,

I’m in the process of migrating a stand alone check_mk 1.2.6 to the 1.6.0 docker image. Everything seems to work except the pnp4nagios/service graphs.

No data is being updated when the var/pnp4nagios directory is empty, so I added the pnp4nagios data from the old installation and now it does show the service graph for services but it is only showing the old data. No new data is being added.

Also when I go to the Host Graph I get a red box saying the HOST_time.rdd file is missing.

I do see that a perfdata.dump is being updated:
root@checkmk-deployment-7f9f68cfc7-qp7ms:/pnp4nagios# ls -latrh
total 48M
drwxr-xr-x 3 checkmkconfig checkmkconfig 6.0K Oct 13 15:48 .
drwxr-xr-x 115 checkmkconfig checkmkconfig 6.0K Oct 13 16:13 perfdata
drwxr-xr-x 1 root root 106 Oct 14 10:36 …
-rw-r–r-- 1 checkmkconfig checkmkconfig 48M Oct 14 11:20 perfdata.dump

but that is everything.

Do you know how I can fix this?

Hi,
the format of metrics in pnp has changed between 1.2.6 to 1.6. You can try to convert with:

cmk --convert-rrd

Cheers,
Christian

Hi Christian,

Thanks for your reply. I tried executing the command but I’m getting the following error:

OMD[checkmkconfig]:~$ cmk --convert-rrd
ERROR: option --convert-rrd not recognized

Also I don’t mind not getting the old data in there. I tried removing an existing host, then remove the host directory in the perfdata directory, then added the host again but nothing happens in the perfdata directory.