Checkmk raw installation error

CMK version: 2.0.0p24 (stable)
OS version: Ubuntu 20.04.4

Error message:

Running into an error when trying to run the .deb installer file for Checkmk raw. It says there are unmet dependencies, but the dependencies are not installable. The dependencies it can’t install are libperl5.32 and libffi8ubuntu1

Any suggestions on how to fix this?

Check your repositories. I’ve run into that error before if I was missing a repo.

Here is a list of the repositories on my server. Do you think it looks ok?

They look fine to me.

I figured it out. I am running Ubuntu 20.04 but I downloaded the Ubuntu 21.10 version of Checkmk.

I feel so stupid now, lol