Checkmk Raw on Debian 10 - Perl issues

Hello,

I’m trying to install Checkmk Raw Edition (2.0) on a clean Debian 10 server. First off, I needed to install some dependencies manually (by downloading the corresponding deb packages from https://debian.pkgs.org):

  • libevent-2.1-6_2.1.8-stable-4_amd64.deb
  • libffi6_3.2.1-9_amd64.deb
  • libreadline7_7.0-5_amd64.deb
  • perl-modules-5.28_5.28.1-6+deb10u1_all.deb
  • libperl5.28_5.28.1-6+deb10u1_amd64.deb

The installation then went through and I was able to create a site and start monitoring. As for now, the only thing I’ve noticed is that performance graphs are not working. When trying to view a graph, I get the error “No historic metrics recorded but performance data is available. Maybe performance data processing is disabled.” In the log rrdcached.log (I think) I noticed that process_perfdata.pl failed with some error code.When running it manually, I get the error “HiRes.c: loadable library and perl binaries are mismatched”.

Somehow, I figured I need to use Perl version 5.28 (as it’s a dependency). Every where I look on the Internet, I’m told to use Perlbrew. As root, I’m able to get Perlbrew working by installing and switching to perl-5.28.1. When changing “use lib ‘/omd/versions/2.0.0p12.cre/lib/perl5/lib/perl5’;” in the script to “use lib ‘/root/perl5/perlbrew/perls/perl-5.28.1/bin’;” and running the script after that, I get an “error” that I should’t run it as root. Good, I thought, and tried to get Perlbrew working as the site user as well. However, when switching to the site user (omd su ) and trying to run any Perlbrew command, I get the same annoying message; “loadable library and perl binaries are mismatched”. Instead I tried to use the perl version now installed in the root directory, but of course the site user does not have access to the root folder.

It seems like I have reached a dead end. I have no idea how to get things up and running fully. Can I somehow downgrade Perl system-wide, or do I need to update something in Checkmk?

The performance graphs are the only parts who need the perl things.
Is it possible that the Perl installed in your system was manually upgraded to a newer version?
I have here a Debian 10 test system and there are no problem with dependencies and wrong Perl versions.

I have installed a few things before Checkmk, such as Exim. Maybe Perl got updated there.

What version of Perl do you have running on your Debian 10 server (as the site user when running “perl - v”)?

It is the same version inside the site as it outside in the system.
5.28.1
Installed are only these 5.28.1-6 packages.

We had the same problem before inside the forum and the reason was a manually installed other version of perl. You can have a look at your apt sources files?

Hmm, I’m a bit embarrassed. I was about to reinstall my machine and noticed I was running Debian 11. To be fair, It’s a mess finding the right ISO at Debian’s web page. :wink:

Is it safe to say that Checkmk is not compatible with Debian 11, or should it work there as well?
I will anyhow try to get it up and running on Debian 10 instead (as Debian 11 is still fresh).

Yep, the installation went through without any dependencies issues, Perl is now version 5.28.1, and all performance graphs are working.

As such, the problem is solved - Checkmk is working as intended on Debian 10, but not Debian 11. :wink:

There are some threads about the problem that until now no build for Debian 11 is available.