CheckMK Server - get_magic_quotes_runtime() is deprecated

OS: SLES 15.1
OMD - Open Monitoring Distribution Version 1.6.0p11.cre

We have been running a checmk server for ~6months without issue, but when selecting the “graph” option on any of the services we are now seeing the following error:
image

This appears to have coincided with a “zypper update” which did the following:

The following 8 NEW packages are going to be installed:
  libbind9-1600 libdns1605 libirs1601 libisc1606 libisccc1600 libisccfg1600 libns1604 libuv1

The following 4 packages are going to be upgraded:
  bind-utils libproxy1 python3-bind sysuser-shadow

4 packages to upgrade, 8 new.

The error appears to be PHP related, but I’m not familiar with it.

Does anyone have any suggestions?

You can look at this post and make the changes mentioned there.


The problem is a to new PHP version :slight_smile:

Thanks Andreas for the swift response :slight_smile:
Yeah it looks like we’ve gone from 7.2 -> 7.4 at some point in the near past.
I’m looking at downgrading the version to 7.2 (if I can get my hands on the package/dependancies) else I’ll follow your suggestion.

Thanks again