Cisco ethernet interfaces

How can Checkmk be so far off with interface numbers? I have an ASR920 the interface numbers start at Gi0/0/0 Checkmk starts at Interface 1. I also have a 3850 the interface numbers start at Gi1/0/1 Checkmk started at Interface 3.
Checkmk version - Raw 1.6.0p17

This is no interface number, this is the interface description or alias.
If you don’t configure the “Interface and switch port discovery” rule to use the alias or description it uses the index number. And index 3 for the first physical interface looks ok.


Perfect, that was my missing piece. Thank you!
Now is there a way to shorten the description? lol
GigabitEthernet0/0/5 to something like Gi0/0/5

Yes and no :slight_smile:
One of my colleagues wrote many networking plugins and also he is a fan of short names
This link shows an example of short names used in an inventory plugin.

A function like the one he used should also be possible to include in the main interface check for the naming of the services.
But it is not existing at the moment, that’s the reason for the no.

1 Like

Thanks again, great information!

Maybe you should read this for some more ideas:

1 Like

Since making the change to “Network Interface and Switch Port Discovery”, setting “Appearance of network interface” to “Use description” the server/VM is having performance issues. CPU load average is high, Check_MK and Check_MK Discovery service timeouts. I have 10 cores and 16G ram allocated to it. I have it monitoring about 370 devices and roughly 300 are using SNMP the rest are either just ping or CheckMK agents for servers. Seems like a minor change to require more resources to be thrown at it. I can throw more resources at the VM but thought maybe there might be something else I need to look at.

Followed the blog post and made all of the suggested changes. Seeing a lot more now, tripled my Services. Going to see if I can get 14 vCPU allocated and bump it to 32G ram. Hopefully that’s all I need.

Only the increased number of interfaces cannot lead to such problems. Can you check the check interval for your “Check_MK Discovery” and “Check_MK HW/SW Inventory” service if they exist on your devices.
For only the interfaces check, CheckMK pulls the complete table also if you only check 1 interface. I hope you have not enabled to also monitor interfaces with status “admin down” :wink:

1 Like

I think you nailed it, Main directory has:
Service name is Check_MK Discovery 10 minutes - deleting
Service name is Check_MK HW/SW Inventory 1 days
I have another server in my home lab that doesn’t have “Service name is Check_MK Discovery” set.
And no I didn’t enable admin down interfaces, I read the blog post :slight_smile:
I can see I need to browse more of the blog, that was a great post.
Thanks for your help.

“Check_Mk Discovery” you can set to 4 or 6 hours that should be ok.

1 Like