Error for each distributed host in web.log after upgrade "failed to create site config directory"

I have seen similar posts and read the instructions here Failed to create site config directory - Checkmk Knowledge Base - Checkmk Knowledge Base however I have tried to change the permissions or chown to the . on all the directory listed but the error does not seem to be clearing.

The error appears when trying to query services for each Distributed node config.

It also appears when trying to publish the configs to the nodes.

It seems its complaining about something in the /omd/sites//local directory. But it is also complaining about not being able to create a hard link in a sub directory - have been looking through them trying to see which does not have the correct permission and changed ownership and permission on any file listed but this does not seem to change the errors.

Any ideas …

sample error below :slight_smile:
2021-11-23 15:10:48,809 [40] [cmk.web.CMESnapshotDataCollector 3920] http://rpsvmh05/SiteMaster/check_mk/ajax_service_discovery.py/SiteMaster/check_mk/ajax_service_discovery.py Failed to clone files from /omd/sites/SiteMaster/local to /omd/sites/SiteMaster/var/check_mk/site_configs/63da1b6d-29ce-4f2f-b406-5e6e81df316c/RPSVMO102: b"cp: cannot create hard link '/omd/sites/SiteMaster/var/check_mk/site_configs/63da1b6d-29ce-4f2f-b406-5e6e81df316c/RPSVMO102/local/share/check_mk/web/htdocs/themes/classic/images/sidebar_top.png' to '/omd/sites/SiteMaster/local/share/check_mk/web/htdocs/themes/classic/images/sidebar_top.png': File exists\ncp: cannot create hard link '/omd/sites/SiteMaster/var/check_mk/site_configs/63da1b6d-29ce-4f2f-b406-5e6e81df316c/RPSVMO102/local/share/check_mk/web/htdocs/themes/facelift/images/mk-logo.png' to '/omd/sites/SiteMaster/local/share/check_mk/web/htdocs/themes/facelift/images/mk-logo.png': File exists\ncp: cannot create hard link '/omd/sites/SiteMaster/var/check_mk/site_configs/63da1b6d-29ce-4f2f-b406-5e6e81df316c/RPSVMO102/local/share/check_mk/web/htdocs/themes/modern-dark/images/mk-logo.png' to '/omd/sites/SiteMaster/local/share/check_mk/web/htdocs/themes/modern-dark/images/mk-logo.png': File exists\n"

Have you made sure all the files in local are owned by the site user? Do a sudo chown -R $SITE_USER:$SITE_USER /omd/sites/$SITE/local to be sure.

Also, it seems like you want to set a custom logo, is that right?

1 Like

Hi Robin,

Opened a case - it seems that the logo was already there …so if i delete the file it works.

However I have tried uploading a custom log again and the issue re-occurs so seems to be something to do with this…and version 2

You mean you open a ticket with the tribe? Then my colleagues will take good care of you. If relevant maybe you can update here what you learned.

But because you did not state so explicitly: Did you verify the permissions?