Fritz-Agent funktioniert in der bash aber Agent im Wato liefert keine Daten

Ich nutze Version 1.6.0p13 (unter armhf auf Raspi) und habe zwecks Ausschlussverfahren gerade auch noch die Version 1.6.0p18 getestet. Ich möchte gern meine Fritzbox 7412 (mit aktueller Firmware) monitoren.
Laut https://checkmk.de/cms_check_fritz_config.html gibt es dafür den bereits im checkmk enthaltenen “Supported Agents: FRITZBOX”. Ein manueller Test auf der bash funktioniert auch:
abc@cmk:~# /opt/omd/versions/1.6.0p18.cre/share/check_mk/agents/special/agent_fritzbox 192.168.1.1
<<>>
VersionOS 137.06.86
VersionDevice AVM FRITZ!Box 7412 (UI)
NewVoipDNSServer1 217.237.149.xxx
NewDNSServer2 217.237.151.xxx
NewDNSServer1 217.237.149.x
NewVoipDNSServer2 217.237.151.xxx
NewIdleDisconnectTime 0
NewLayer1DownstreamMaxBitRate 98282000
NewWANAccessType DSL
NewByteSendRate 4108
NewPacketReceiveRate 0
NewConnectionStatus Connected
NewRoutedBridgedModeBoth 1
NewUptime 39237
NewTotalBytesReceived 1035751932
NewPacketSendRate 0
NewPhysicalLinkStatus Up
NewLinkStatus Up
NewLayer1UpstreamMaxBitRate 36999000
NewTotalBytesSent 271753557
NewLastConnectionError ERROR_NONE
NewAutoDisconnectTime 0
NewExternalIPAddress 93.209.xxx.xx
NewLinkType PPPoE
NewByteReceiveRate 3713
NewUpnpControlEnabled 0

Also habe ich nach der Anleitung https://forum.checkmk.com/t/fritzbox-und-reapter-hinzufugen/17990/10 versucht, das ganze zum laufen zu bekommen.
Wenn ich unter Diagnostic einen Check mache, liefert mir nur die Box Agent folgendes in grüner gefärbter Box Farbe zurück: 
Agent
Retry this test
<<<fritz>>>
VersionOS None
VersionDevice None

Eingerichtet habe ich in WATO folgendes:

1.) Unter "Hosts" habe ich den "Hostname" "FritzBox" vergeben mit der IPv4 Adresse 192.168.1.1 und später unter "Data sources" den agent_fritzbox mit zwei gesetzten Haken zugewiesen

2.) Unter "Host & Service Parameters" "Datasource Programs" "Check state of Fritz!Box Devices" habe ich "create rule in Folder Main directory" erstellt mit Descrition: Fritzbox, "Host tags" den zuvor angelegten "Data sources" "agent_fritzbox"  
sowie "Explicit hosts" FritzBox zugewiesen


3.) Unter "Tags" hab ich unter "Tag" eine neue "Tag Group" 'agent_fritzbox' erstellt mit folgenden Parametern:
Tag group ID = agent_fritzbox
Title = agent_fritzbox
Topic Data sources
Dazu habe ich dor noch unter "Tag choices" die Tag ID "agent_fritzbox" mit dem Titel "agent_fritzbox" erstellt

In der Fritzbox habe ich unter Heinmetz/Netzwerkeinstellungen den Punkt "Statusinformationen über UPnP übertragen" aktiviert. Der manuelle Test per bash funktioniert ja auch. Kann es sein, dass trotzdem für den Agent noch das Feld "Zugriff für Anwendungen zulassen" aktiviert werden muss?
Falls jemand eine funktioierendes Fritbox Monitoring hat, wäre ich über jeden Hinweis dankbar. Auch ein Link zu einer funktionierenden Anleitung (auch in Englisch) wäre toll.

VG Heiko

Um zu überprüfen ob dein Host richtig konfiguriert ist bitte mal folgendes machen.

Als Site User
cmk -D hostname
Bei “Type of agent” sollte sich folgender Eintrag finden
Program: /omd/sites/<sitename>/share/check_mk/agents/special/agent_fritzbox ‘192.168.xxx.xxx’

Diesen Befehl einfach mal manuell als Site User ausführen, dies muss funktionieren.
Danach einfach mal ein “cmk --debug -vvI hostname” und er sollte paar Services finden.

Die meiste deiner Konfiguration ist so nicht notwendig. Einzig das Datasource Program muss richtig gesetzt sein und der Host muss/sollte die Einstellung “Normal Checkmk agent, or special agent if configured (Default value)” haben.

1 Like

Ein Hallo und Danke für die schnelle Reaktion auf meine Anfrage.
Ich habe die bestehende (zu komplizierte Konfig) noch mal gelöscht (auch die Tag group) und den Host FritzBox neu angelegt und nur bei “Data sources” die Option “No Checkmk Agent, all configured special agents” aktiviert.

OMD[live]:~$ cmk -D FritzBox

FritzBox
Addresses: 192.168.1.1
Tags: [address_family:ip-v4-only], [agent:special-agents], [criticality:prod], [ip-v4:ip-v4], [networking:lan], [piggyback:auto-piggyback], [site:live], [snmp_ds:no-snmp], [tcp:tcp]
Labels:
Host groups: check_mk
Contact groups: all, check-mk-notify
Agent mode: No Checkmk agent, all configured special agents
Type of agent:
Program: /omd/sites/live/share/check_mk/agents/special/agent_fritzbox ‘192.168.1.1’
Process piggyback data from /omd/sites/live/tmp/check_mk/piggyback/FritzBox
Services:
checktype item params description groups


fritz.config None {} Configuration
fritz.conn None {} Connection
fritz.wan_if 0 {‘state’: [‘1’], ‘errors’: (0.01, 0.1), ‘speed’: 98282000} Interface 0
fritz.link None {} Link Info
OMD[live]:~$ cmk --debug -vvI FritzBox
Discovering services on: FritzBox
FritzBox:

  • FETCHING DATA
    [special_fritzbox] No persisted sections loaded
    [special_fritzbox] Not using cache (Don’t try it)
    [special_fritzbox] Execute data source
    [special_fritzbox] Calling external program “/omd/sites/live/share/check_mk/agents/special/agent_fritzbox ‘192.168.1.1’”
    [special_fritzbox] Write data to cache file /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Try aquire lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Got lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Releasing lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Released lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Loading autochecks from /omd/sites/live/var/check_mk/autochecks/FritzBox.mk
    [piggyback] No persisted sections loaded
    [piggyback] Execute data source
    No piggyback files for ‘FritzBox’. Skip processing.
    No piggyback files for ‘192.168.1.1’. Skip processing.
  • EXECUTING DISCOVERY PLUGINS (5)
    Trying discovery with: fritz.wan_if, fritz, fritz.conn, fritz.config, fritz.link
    fritz does not support discovery. Skipping it.
    Try aquire lock on /omd/sites/live/var/check_mk/autochecks/FritzBox.mk
    Got lock on /omd/sites/live/var/check_mk/autochecks/FritzBox.mk
    Releasing lock on /omd/sites/live/var/check_mk/autochecks/FritzBox.mk
    Released lock on /omd/sites/live/var/check_mk/autochecks/FritzBox.mk
    SUCCESS - Found no new services, no new host labels

Danach tauchten automatisch die 4 gesuchten Services (Configuration,Connection, Interface 0 und Link info) auf. Leider bleiben diese seit 13 Minuten im State UNKN.

Sind die vom agent_fritzbox angefragten Daten , welche zurückgeliefert werden inkompatibel, z.B. auf Grund nicht unterstütztem Fritz Box Modell?

OMD[live]:~$ /omd/sites/live/share/check_mk/agents/special/agent_fritzbox ‘192.168.1.1’
<<>>
VersionOS 137.06.86
VersionDevice AVM FRITZ!Box 7412 (UI)
NewVoipDNSServer1 217.237.149.205
NewDNSServer2 217.237.151.51
NewDNSServer1 217.237.149.205
NewVoipDNSServer2 217.237.151.51
NewIdleDisconnectTime 0
NewLayer1DownstreamMaxBitRate 98282000
NewWANAccessType DSL
NewByteSendRate 1479
NewPacketReceiveRate 0
NewConnectionStatus Connected
NewRoutedBridgedModeBoth 1
NewUptime 59641
NewTotalBytesReceived 2234459679
NewPacketSendRate 0
NewPhysicalLinkStatus Up
NewLinkStatus Up
NewLayer1UpstreamMaxBitRate 36999000
NewTotalBytesSent 1577819704
NewLastConnectionError ERROR_NONE
NewAutoDisconnectTime 0
NewExternalIPAddress 93.209.176.89
NewLinkType PPPoE
NewByteReceiveRate 11878
NewUpnpControlEnabled 0

Hier noch der aktuelle Status des Hosts:

Muss ich da noch spezielle Parameter für die UNKN Services definieren ?

THX nochmal und viele Grüße
Heiko

Naja immerhin das Discovery ging ja :slight_smile:
Nun auf der Command Line noch das “cmk --debug -vvn FritzBox” probieren.
Immerhin dein “Connection” Check müsste “Connected” anzeigen da dies im Agent Output auf die Schnelle zu finden ist.

OMD[live]:~$ cmk --debug -vvn FritzBox
[cpu_tracking] Start with phase ‘busy’
Check_MK version 1.6.0p18
Try aquire lock on /omd/sites/live/tmp/check_mk/counters/FritzBox
Got lock on /omd/sites/live/tmp/check_mk/counters/FritzBox
Releasing lock on /omd/sites/live/tmp/check_mk/counters/FritzBox
Released lock on /omd/sites/live/tmp/check_mk/counters/FritzBox
Loading autochecks from /omd/sites/live/var/check_mk/autochecks/FritzBox.mk

  • FETCHING DATA
    [cpu_tracking] Push phase ‘ds’ (Stack: [‘busy’])
    [special_fritzbox] No persisted sections loaded
    [special_fritzbox] Not using cache (Don’t try it)
    [special_fritzbox] Execute data source
    [special_fritzbox] Calling external program “/omd/sites/live/share/check_mk/agents/special/agent_fritzbox ‘192.168.1.1’”
    [special_fritzbox] Write data to cache file /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Try aquire lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Got lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Releasing lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    Released lock on /omd/sites/live/tmp/check_mk/data_source_cache/special_fritzbox/FritzBox
    [cpu_tracking] Pop phase ‘ds’ (Stack: [‘busy’, ‘ds’])
    [cpu_tracking] Push phase ‘agent’ (Stack: [‘busy’])
    [piggyback] No persisted sections loaded
    [piggyback] Execute data source
    No piggyback files for ‘FritzBox’. Skip processing.
    No piggyback files for ‘192.168.1.1’. Skip processing.
    [cpu_tracking] Pop phase ‘agent’ (Stack: [‘busy’, ‘agent’])
    Configuration OK - Auto Disconnect Time: 0, DNS-Server1: 217.237.149.205, DNS-Server2: 217.237.151.51, VoIP-DNS-Server1: 217.237.149.205, VoIP-DNS-Server2: 217.237.151.51, uPnP Config Enabled: 0
    Connection OK - Status: Connected, WAN IP Address: 93.209.180.111, Up since Thu Oct 29 03:40:30 2020 (0d 04:34:00)
    Interface 0 OK - [WAN] (up) 98.28 Mbit/s, In: 0 bit/s (0.0%/98.28 Mbit/s), Out: 0 bit/s (0.0%/37 Mbit/s)
    Link Info OK - Link Status: Up, Physical Link Status: Up, Link Type: PPPoE, WAN Access Type: DSL
    [cpu_tracking] End
    OK - [special_fritzbox] Version: unknown, OS: unknown, execution time 0.5 sec | execution_time=0.496 user_time=0.050 system_time=0.040 children_user_time=0.260 children_system_time=0.050 cmk_time_ds=0.098 cmk_time_agent=0.005

Die Daten auf shell Ebene sehen ja auch gut aus. Nur warum bleiben die Services im Status UNKN ?

Ich muss meine Aussagen teilweise korrigieren. Nachdem mir angezeigt wurde, dass die Services nicht mehr monitoret werden, habe ich nacheinander nochmal die drei Befehle ausgeführt:
cmk -D FritzBox
cmk --debug -vvI FritzBox
cmk --debug -vvn FritzBox

Gehe ich dann über die Host Ansicht auf die FritzBox, sehe ich nur zwei Services:


Klicke ich in diesem Menü nochmal auf WATO und Services, werden mir korrekt alle vier Services angezeigt , als bereits “Monitored services”.

Warum übernimmt es die Daten nicht ? Oder habe ich irgendwo einen Denkfehler?

Auf der Shell nach den ganzen Test Befehlen noch ein “cmk -R”
Dann sollten die Checks mit den Werten wie im letzten WATO Screenshot auch im monitoring sein.

Nur die Befehle absetzen hat nicht geholfen. Ich habe den Host noch mal gelöscht und mit leicht geänderter Schreibweise neu angelegt, den Spezial_agenten verknüpft per “explizit Host” und dann die vier Befehle abgesetzt. Danach hat es funktioniert und alles wird perfekt angezeigt :grin:
Danke für die Unterstützung.
EIne Frage stellt sich mir aber noch. Warum funktioniert das Einrichten nicht mit Boardmitteln? Ich habe bisher noch nie die Kommandozeile mit cmk und den Debug Mode benötigt. Gibts da eine Vermutung oder gar Erkenntnis dazu ?

viele Grüße
Heiko

Das geht auch ohne Command Line. Nur bei Fehlersuche ist das halt einfacher da es über die Debug und Verbose Schalter mehr Ausgabe gibt wie im Web.

Normal - Fritzbox anlegen - Special Agent zuweisen - Discovery im Web und fertig

2 Likes