Hosts are missing in "All hosts" snapin

Hello,

on the sidebar in Check_MK web UI I’m using the snapin “all hosts”.
I just noticed that at least two hosts are not listed, but this was already working.
The “all hosts” view shows them. The particular hosts are in the same folders as working ones.

I already created a new user to make sure it’s not related to any permission issues, but that does not seem to be the case.

Installed version is 1.6.0p18.

Does anybody know what may cause that? Is it possible to exclude hosts (by accident) from this sidebar snapin?

Thanks.
Clemens

Are the hosts in downtime?

No, they aren’t, and even they would be, they should show up in the all hosts snapin.

Hi,
how many hosts are in checkmk? Did you try to increase " Limit the number of rows shown in tables". You will find it in Global settings.

Cheers,
Christian

Hi,

good question - I do have 102 hosts in the particular side and the affected hostnames start with x…
I just increased the value from 100 (default) to 200, but hosts still don’t show up.

BR
Clemens

Hi,
I had a look in the code. The result is, that there is a hard coded limit set to 100 for the query.
That’s the reason for the missing hosts.
You will find this information in: ~/lib/python/cmk/gui/plugins/sidebar/hosts.py
Cheers,
Christian

1 Like

Thanks for your research!
Would it be possible to link this count to the previous mentioned “Limit the number of rows” or create a separate option within the global settings?

BR
Clemens

If you want this, open a request to the developers.
From my point of view, it’s not a good idea to have all hosts in the sidebar.
I would like to prefer the virtual host tree.
Cheers,
Christian