How to configure mk_oracle_crs plugin

In CheckMK Enterprise 1.6.0p19 I’ve been trying to configure monitoring Oracle RAC database.
Plugins mk_oracle and mk_oracle_crs are copied in /usr/lib/check_mk_agent/plugins, but when I do discovery no cluster sevices regarding mk_oracle_crs are found. Only services regarding mk_oracle plugin including ASM instance, ASM diskgroup are found.
Just to add os user oracle is owner of RDBMS software and os user grid is owner of Grid Infrastructure software.
Is there any manual, docs how to configure it?
Thank you.

Can you please run the plugin directly from command line:
MK_CONFDIR=/etc/check_mk/ /usr/lib/check_mk/plugins/mk_oracle_crs (if all configuration is default)

If there is no output exept for the headers we can analyse this further.

EDIT:
Maybe as information, the crs-commands are run as root, not us GI- or DB- user with environment. The plugin refers mainly to the crsctl function to get the most information.

I executed the following commands as root user

export MK_CONFDIR="/etc/check_mk/"

/usr/lib/check_mk_agent/plugins/mk_oracle -t

and it works, but with mk_oracle_crs there is a error

/usr/lib/check_mk_agent/plugins/mk_oracle_crs -t

-bash: ./mk_oracle_crs: /bin/bash^M: bad interpreter: No such file or directory

Just to add crsctl can be run as root, but also as grid user.

Seems like the file was uploaded to the linux server in windows format (see ^M). Please check that the mk_oracle_crs is in right format.

Good news!!
It wasn’t windows format, but something wrong was with plugin format.
I selected all and copied contents of mk_oracle_crs plugin from CheckMK server and paste it in vi editor creating mk_oracle_crs in Linux server, and it works!!
Previously I first paste all in windows notepad creating mk_oracle_crs file and copied such a file to Linux server, that isn’t work.
Thank you very much!!

Great that it’s working now.

Keep in mind, linux and windows are workin with different characters for newlines. The ^M symbol tells you there is an additional carriage return (windows newline = line feed + carriage return; linux newline = line feed) at the end of each line. As far as I know notepad produces such problem where programs like notepad++ doesn’t (even if copying between the clipboard). You can fix or avoid this by using the command dos2linuxon your file or in vi by setting :set fileformat=linux before writing your buffer.

Would you please mark the post as solution so that other people can find the solution easier?

Yes, it is a solution, I marked it.
Thank you again.