How to Ignore Certain Backups with mssql.vbs

Hi there,

We are just starting out monitoring MS SQL with Checkmk. We installed the mssql.vbs plugin into the appropriate directory and it seems to be working properly.

What we would like to do now is tell Checkmk not to raise a Warning if no backups are found for certain databases. For example, we are not backing up tempdb and Checkmk shows the service in a Warning state.

We could go to each host and manually exclude the tempdb backup service, but this seems to violate the principle of “do as much as possible with rules”.

What is the “right” way to tell Checkmk that the lack of backup is a non-issue for certain databases?

In case it matters, we are using Checkmk RAW v2.1.0.

Thank you in advance,
Jason Smyth

the rule MSSQL Backup summary should help to solve your problem.


Hello Jason,
You may use the rule kdeutsch mentioned to force the state to OK for Backup not found.
We complete disable the services for built in DB´s
Look for the rule ‘Disabled services’

Thats what we use in that rule:

Service name is .*?Transactionlog .*?\.(tempdb|master|msdb|model|dba_tools)\..*?[Ll]og, begins with .*? (tempdb|master|msdb|model|dba_tools) Database, begins with .*? (tempdb|master|msdb|model|dba_tools) File Sizes, begins with .*? (tempdb|master|msdb|model|dba_tools) Transactions, begins with .*?Catalog_Metadata (tempdb|master|msdb|model|dba_tools) cache_hit_ratio, begins with .*? (tempdb|master|msdb|model|dba_tools).modellog, begins with .*? (tempdb|master|msdb|model|dba_tools) Sizes, begins with .*? (tempdb|master|msdb|model|dba_tools) log_cache_hit_ratio, begins with .*? (tempdb|master|msdb|model|dba_tools).modeldev or begins with .*? (tempdb|master|msdb|model|dba_tools) Backup



Thank you both for your feedback. We went with the MSSQL Backup summary rule solution.

In case any future readers struggle with the format of the Instance & tablespace name parameter the way we did, the following regex matches the TempDB in a default MS SQL instance: MSSQL_MSSQLSERVER tempdb$.

Thanks again,
Jason Smyth