Implementing CheckMK Backups - a few questions

we currently have distributed monitoring environment with a handful of remote monitoring nodes.
this is on 2.1.0p9.cre

  1. how exactly does CheckMK Backup work with relation to this?
    i.e. would I have to log into each node and configure a backup job?

  2. Setup → Maintenance → Site Backup requires I setup a Backup Target -

I try to create a folder called /opt/omd/backups/ which is local to the check_mk server and when I use this in the destination I get an error: “Please enter a valid absolut pathname with / as a path separator” –
other attempts give me “you have to provide a canonical path” — not sure what I’m doing wrong…

  1. is there a way to does the configuration of Backup specify retention period ?
    i.e. I’d like to schedule nightly backup, but only keep the last 30days worth…

The backup function of checkmk does not know anything about rentention. It just overwrites the backup target.

If you want to keep more than one version of a backup you need a backup system that collects the backup checkmk has written.

You could create 7 backup jobs for each day of the week in checkmk and get a retention period of 7 days.

thanks! I have confirmed this behaviour and I guess it makes sense to setup individual jobs for each day…
7-day retention is probably more than enough.

hopefully someone can help with #1 and #2.
I’m not sure if I need to log into each distributed node and setup the same, or is everything safely backed up from the master node?

as for #2, I used /tmp and it worked, but I know this isn’t the final/expected location… will test further and update.

thx

I’ve had the same error message. If I remember correctly, the final slash seems to confuse Checkmk and leads to this (equally confusing) error message. Try /opt/omd/backups without the trailing /.

I’d call that a bug, since the path should work with a trailing slash just the same.

I actually tried that as well, same error.
I’m about to test out an NFS mount that has been provided to me, hopefully that works =)

Strange. Perhaps because it’s below /opt/omd (which I would leave alone).

I’m using /var/backups/checkmk/mysite without any problem.
The “Mountpoint” option needs to be off since it’s just a directory on the local disk.
And make sure the site user has proper permissions on the directory
(chown mysite:mysite /var/backups/checkmk/mysite).

1 Like

That should resolve the issue. I had the same problem and after giving the cmk-user the proper permissions on my desired directory it worked.