Is CheckMK 1.6 able to communicate with 2.1 agents?

We have the case that a customer with a legacy 1.6 instance also wants to query some hosts. We are running checkmk 2.1. Are we forced to downgrade to the 1.6 agent on theses hosts or is checkmk 1.6 able to query 2.1 agents?

Michael

Checkmk 1.6 can only query agents up to 1.6 as newer agents may output their data differently.

The basic agent output should work and works for me. Only the plugins can make it difficult because their output can vary from version to version.

I would not rely on that.

2 Likes