Just activated Wato, but

I didn’t use Wato until now (we have a huge site, witch check_mk’s configuration mostly automated by scripts), but I needed to create a Wato user.
The /etc/check_mk, /etc/nagios folders have all both group access to nagios user.
The /var/lib/check_mk folder have these perms :

-rw-r--r--  1 nagios root    0 Jun 24 09:22 acknowledged_werks.mk
drwxr-xr-x. 2 nagios root    6 May 28 08:48 autochecks
drwxr-xr-x. 2 nagios root    6 May 28 08:48 counters
drwxrwxr-x. 2 apache nagios 20 Jun 24 09:21 log
drwxr-xr-x. 2 nagios root    6 May 28 08:48 logwatch
drwxr-xr-x. 2 nagios root    6 May 28 08:48 precompiled
drwxrwx---. 6 apache nagios 85 Jun 24 09:26 wato
drwxrwxr-x. 4 root   apache 36 Jun 24 09:26 web

But when I activate my change, I get this message :

Error running check_mk --automation reload -- (exit code 1):

[Errno 13] Permission denied

On what folder/file are permissions incorrect ?

what does the log saying ???

as site user

Exactly the same message

IMHO in ~local path are possibly the some file permissions not correct

Just forgot to mention : we do not use OMD either, but a pacjaged version of check_mk raw


that sounds interesting but make it complicate to give some support with out the knowledge of the installation structure …
What version do you use ??

Could you try the following (as the site user) and see if it shows any more information:

cmk --debug -vv -R

This regenerates core config and triggers a reload.

Hi, lkoenig
Tried that, it reloads correctly. The error still persists when I activate the change in WATO

Anyway, I tried this as nagios user I got a stacktrace:

-sh-4.2$ check_mk --debug --automation reload
Waiting for exclusive lock on /etc/check_mk/main.mk.
Traceback (most recent call last):
File "/usr/share/check_mk/modules/check_mk.py", line 5238, in <module>
do_automation(a, args)
File "/usr/share/check_mk/modules/automation.py", line 98, in do_automation
result = automation_restart("reload")
File "/usr/share/check_mk/modules/automation.py", line 469, in automation_restart
os.rename(objects_file, backup_path)
OSError: [Errno 13] Permission denied

that gives a hint, just checking

The permissions were incorrect on /etc/nagios/object
Thanks to all

Even if it feels like self-praise, mark your answer as the solution to your problem, so others who might stumble upon this one can find it quickly. Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed. Contact an admin if you think this should be re-opened.