Localhost NFS mounts not visible

Hello,

Check_MK version: 1.6.0p11
Check_MK Host OS: Centos 6.10
Client Host OS: Red Hat 7.4

When upgrading agent from 1.5.x to 1.6.x I do not see anymore NFS filesystems from df in GUI, services like fs_/xxx. I compared the agents, and 1.6 agent have by default excluded nfs.

excludefs="-x smbfs -x cifs -x iso9660 -x udf -x nfsv4 -x nfs -x mvfs -x prl_fs -x squashfs -x devtmpfs"

Then I found this article - “Make filesystem types ignored during discovery configurable via WATO”. I guess it is in Host & Services parameters -> Parameters for discovered services -> Discovery parameters for filesystem checks. I’ve unchecked the nfs in theory that it will not exclude NFS filesystem. But it doesn’t do anything.

Further, in check_mk_agent is df -PTlk ${excludefs} | sed 1d.

-l is working pretty well here, isn’t the reason why setting from GUI is not working, because agent is already sending filtered output to Check_MK?

I tried to remove the l parameter from df, but still can’t see certain NFS filesystems.

Output from df -PTk from one server (just splitted to two images to cut the other filesystems)


NFS filesystems mounted from localhost are not visible in GUI.
NFS filesystems mounted from IP are visible in GUI.

Am I explaining to myself something wrong about “Discovery parameters for filesystem checks”?
Is my only option to see NFS filesystems in GUI by using check_mk_agent version before 1.6.x?

The found discovery option has no function as it is not used anywhere only inside the check :slight_smile:

NFS and CIFS is checked and returned from agent with the sections <<<nfsmounts>>> and <<<cifsmounts>>>. Do you see your mounts there?

Then for what is that discovery function? :slight_smile:
I can see the mounts under section <<<nfsmounts>>> but those are then shown as NFS Mount in GUI, aren’t they?
nfsmounts
2020-11-19 11_53_44-Window

I would like to see them also as fs_/mapr/ so I can watch the graphs.