Monitoring Microsoft SQL

CMK version : 2.0.0 p1
OS version : Ubuntu 18.04.5 LTS

Error message : Services of SQL do not appear in the discovery of services

Hi

I am trying to add a MSSQL server cluster to our monitoring server but it seems the services of SQL don’t seem to get picked up.
Standard services like CPU load / network load and disks are getting picked up fine.

What I have tried:

  • add mssql.ini
  • copy mssql.vbs to service folder
  • add system user to SQL allowed users / added dedicated user to mssql.ini (public role and sysadmin role)
  • re-discovered hosts (tabula rasa method + normal method)
  • Added ‘py’ to the allowed executed scripts in the YML file

I followed these intructions to create my cluster: Monitoring cluster services

Can anyone suggest another approach to try and solve this ?

Followed suggestions here: mssql-giving-error-message-time-string-does-not-match-any-known-pattern/23323 (same result)
Followed suggestions here: mssl-english-not-seen-by-discover-on-new-agent/24353/7 (same result)

If I execute the mssql.vbs file locally, I get lots of out put!, it jst doesn’t seem to flow to CheckMK GIU :frowning:

The agent plugin mssql.vbs belongs in the folder C:\ProgramData\checkmk\agent\plugins.

1 Like

Thanks!
Now most important service does appear! Only 1 error left now:
‘Unable to login’ for the user I created.

Will look into that tomorrow, than,ks again for the help!

I created an AD user to have access to the SQL server, but that didn’t seem to work.
I now created a local SQL user and that works, I can now monitor our SQL cluster without issues.

1 Like