Not able to discovery and it is saying to create to ruleset

Hello Team ,

When we full scan for one device , getting below error .Please help me to resolve this.

Starting job…

  • FETCHING DATA
    [snmp] Execute data source
    ERROR: SNMP error
    snmpget: Timeout

SNMP scan failed: Cannot fetch system description OID .1.3.6.1.2.1.1.1.0. This might be OK for some bogus devices. In that case please configure the ruleset “Hosts without system description OID” to tell Check_MK not to fetch the system description and system object OIDs.
[piggyback] Execute data source
No piggyback files for ‘de03-sw-s901’. Skip processing.
No piggyback files for ‘10.39.224.53’. Skip processing.
Completed.

Device details -
Hardware

Nexus9000 in ACI Fabric mode – Spine and Leaf switches, APIC

Cisco NX-OS 14.2(4i)


when we test the snmp , snmp test works good .

“Retry this test”)](javascript:cmk.host_diagnose.start_test(‘snmpv3’, ‘test’, ‘1592817396/3543042676’):wink: sysDescr: Cisco NX-OS™ aci, Software (aci-n9000-system), Version 14.2(4i), RELEASE SOFTWARE Copyright © 2002-2015 by Cisco Systems, Inc. Compiled 2020/04/21 09:45:55
sysContact: d
sysName: de03-sw-s901
sysLocation: DNPC Paderborn

On command line do a “cmk --debug -D hostname’” and check the shown SNMP config if correct. Then do a “cmk --debug -vvI hostname’” to make a discovery. Do you get some error messages there?

debug output (removed SNMP creds)

de03-sw-s901
Addresses: 10.39.224.53
Tags: [address_family:ip-v4-only], [agent:cmk-agent], [criticality:test], [ip-v4:ip-v4], [networking:lan], [piggyback:no-piggyback], [site:test], [snmp:snmp], [snmp_ds:snmp-v2], [tcp:tcp]
Labels:
Host groups: check_mk
Contact groups: all, check-mk-notify
Agent mode: Normal Checkmk agent, or special agent if configured
Type of agent:
TCP: 10.39.224.53:6556
SNMP (Credentials: ', sha, , , AES, ', Bulk walk: yes, Port: 161, Inline: no)
Services:
checktype item params description groups


OMD[test]:~$
------------------debug -vvI o/p----------------

Discovering services on: de03-sw-s901
de03-sw-s901:

  • FETCHING DATA
    [agent] No persisted sections loaded
    [agent] Not using cache (Does not exist)
    [agent] Execute data source
    [agent] Connecting via TCP to 10.39.224.53:6556 (5.0s timeout)
    [agent] ERROR: timed out
    Traceback (most recent call last):
    File “/omd/sites/test/bin/cmk”, line 94, in
    exit_status = modes.call(mode_name, mode_args, opts, args)
    File “/omd/sites/test/lib/python/cmk_base/modes/init.py”, line 72, in call
    return mode.handler_function(*handler_args)
    File “/omd/sites/test/lib/python/cmk_base/modes/check_mk.py”, line 1498, in mode_discover
    discovery.do_discovery(hostnames, options.get(“checks”), options[“discover”] == 1)
    File “/omd/sites/test/lib/python/cmk_base/discovery.py”, line 134, in do_discovery
    multi_host_sections = _get_host_sections_for_discovery(sources, use_caches=use_caches)
    File “/omd/sites/test/lib/python/cmk_base/discovery.py”, line 906, in _get_host_sections_for_discovery
    return sources.get_host_sections(max_cachefile_age)
    File “/omd/sites/test/lib/python/cmk_base/data_sources/init.py”, line 279, in get_host_sections
    host_sections_from_source = source.run()
    File “/omd/sites/test/lib/python/cmk_base/data_sources/abstract.py”, line 133, in run
    raw_data, is_cached_data = self._get_raw_data()
    File “/omd/sites/test/lib/python/cmk_base/data_sources/abstract.py”, line 182, in _get_raw_data
    raw_data = self._execute()
    File “/omd/sites/test/lib/python/cmk_base/data_sources/tcp.py”, line 100, in _execute
    s.connect((self._ipaddress, port))
    File “/omd/sites/test/lib/python2.7/socket.py”, line 228, in meth
    return getattr(self._sock,name)(*args)
    socket.timeout: timed out

You have configured your device as agent and SNMP.
Please check your configuration inside WATO that it is only SNMP with “no agent”.

Can you tell me exactly where i have to select SNMP with “no agent” ?

In your normal host config inside WATO you can define how to check your host.
There should be only SNMP active.