Performance Daten werden nur unregelmäßig abgefragt

Hallo zusammen,

bei einer SNMP-Abfrage auf einem Server wird nur unregelmäßig der Graph der Bandbreite gefüllt.
perfometer
Dabei ist der Check intervall auf 10 Minuten gesetzt.
check
Zudem wird mir auch gesagt, dass der Cache generiert wurde. Allerdings leider ohne Inhalt.

Meine Frage ist jetzt: Was muss ich einstellen oder ändern um regelmäßige Informationen der Bandbreite im Graphen sehen zu können?

Vielen Dank schonmal im Voraus!

Ich habe auch mal so eine Beobachtung gemacht (bei einer Webseite, deren Zertifikat ich nur alle halbe Stunde abfrage).
Mein Eindruck war, dass man dann auch die Konfiguration der RRD-Datenbank (für diesen einen Service) anpassen muss, so dass sie nicht mehr vom Minutentakt ausgeht.
Vielleicht kann das jemand bestätigen?

1 Like

Bestätigung erfolgt mit einem klaren “Jein” :slight_smile:
Das Problem bei den RRD Datenbanken ist der Punkt Heartbeat in der Konfiguration der RRD Files.
Bei einer klassischen RRD welche auch von PNP4Nagios erstellt wird beträgt der Hearbeat Wert laut Config 8640 Sekunden. In der Enterprise Edition kann dieser auch selbst einfach angepasst werden.
Innerhalb dieser Zeit müssen einfach zwei Werte vorliegen dann wird einfach die Zeit dazwischen nicht mit NaN gefüllt.

Aus dem obigen Graph kann man aber was ganz anderes ableiten wenn man noch sehen würde wie groß die Spikes da sind.
Also die Skala dazu müsste man noch sehen.
Da es sich um ein Netzwerkinterface handelt ist ein Interval von 10 Minuten ganz schlecht.
Wenn auf diesem Interface ordentlich Traffic ist so gibt es im dümmsten Fall innerhalb von 10 Minuten immer einen Counter Überlauf - ist der Check dort if oder if64?

1 Like

Wie @andreas-doehler schon geschrieben hat, erwartet die RRD jede Minute einen Wert. Kommen zu wenige rein, gibt es eben Lücken.
Wenn Du wirklich nur alle 10 Minuten den Wert abfragen möchtest, kannst Du für diese(n) Service Check(s) die RRD-Definition so ändern, dass der Step nicht bei 60, sondern bei 600 Sekunden liegt. Die aufzuhebenden Datenpunkte pro Phase können dann auch auf ein Zehntel reduziert werden, sonst hast Du Messwerte der letzten 40 Jahre im RRD.
Mit cmk -v --convert-rrds hostname werden die RRDs letztendlich dann angepasst.

1 Like


Und der Check dort ist if

Ich habe die Step (precision) auf 600 sec gestellt… Ich denke du meintest das oder?


Hat leider auch nicht funktioniert die Werte im Graphen erscheinen immer noch nicht

Das ist nicht das einzige, was da notwendig ist. cmk --convert-rrds muss auch laufen und dann müssen erstmal neue Werte reinkommen.

1 Like

Leider nein - du brauchst nur innerhalb von 8640 Sekunden zwei Werte das reicht.

Hier liegt das eigentlich Problem begraben.
Bei 32bit Countern auf dem Interface erfolgt ein Überlauf alle 4,3 GByte an übertragenen Daten (ich weiß nicht mehr ob der if Counter signed oder unsigned Int ist - geh mal von unsigned aus)
Bei deinem Traffic kannst du mit einem Check Interval von 10 Minuten eigentlich nie über 200 MBits erreichen. (200MBits --> 10min --> knapp 19GByte) Dein Check Intervall sieht eher aus wie 2 Minuten was bei einer gut ausgelasteten Leitung schon knapp ist für 32 Bit Counter.

Check Interval unbedingt auf 1 Minute stellen.

1 Like

Ich hatte die Step (precision) mal auf 600 gestellt und danach “cmk --convert-rrds hostname” gemacht.
Danach haben sich die Werten im Graphen aber komplett verstellt.


Wie man hier sieht zeigt er angeblich nur 20 Mbit/s an, was aber absolut nicht stimmt und vorher knapp auf 200 war.
Jatzt habe ich das wieder zurück auf die 60 Sekunden gestellt und nochmal den Befehl ausgeführt.

Ist das denn überhaupt der richtige Check Interval den ich da geändert habe?
Und wie kann es sein, dass deswegen die Daten (auch in der Vergangenheit) verstellt sind?

Ich hoffe mal die Step precision ist nicht für alle Graphen geändert worden?
Wenn ja sind auch alle anderen Graphen kaputt nun - Step precision 600 bedeutet alle Werte werden auf 10 Minuten gemittelt. deshalb sind deine 250Mbit nun zu 25Mbit über 10 Minuten geworden.

Bitte mal den Host so konfigurieren, dass alle Checks mit einem Interval von einer Minute ausgeführt werden.
Danach sollte sich ein etwas anderes Bild zeigen.

Zum Thema Heartbeat - da hatte ich mich auch getäuscht, dies ist die einzige Option welche sich nicht in der Enterprise Edition konfigurieren lässt. Dieser ist immer fest bei 8460 Sekunden - Alle ca. 2,25h muss mindestens 1 Messwert ankommen um keine Lücken zu produzieren.