Problem using Legacy Checks / Nagios Checks

Hi. I’m trying to migrate from 1.2.2p2 to 1.6.0.

In old configuration i have something like legacy_checks configured in file. example (It’s just my header, i have many of them):

    legacy_checks = [


  ( ( "check_tcp!80", "TCP HTTP", True), [ "web" ], ALL_HOSTS ),
  ( ( "check_tcp!443", "TCP HTTPS", True), [ "https" ], ALL_HOSTS ),


etc...

They are using checks from extra_nagios_conf.mk
example:

define command{
        command_name    check_udp
        command_line    $USER1$/check_udp -H $HOSTADDRESS$ -p $ARG1$ $ARG2$
        }

They are on server side.

So I want to use them still on new version.
So Now i’ve copied those files to my new configuration.
CMK screams that legacy_checks are deprecated and i should change them to custom_checks - so the files are read and interpreted as they should. After changing to custom_checks all seems to be ok. There are no errors at all.

But there is no sign of those checks on my hosts :slight_smile:

There are many documents around web that I should find this now i WATO, but there is no place for this in my config i think.

Can someone help me where should i look for ? Maybe I need some special plugin to read them?

Any help or clue will be appreciated

Thanks

Easiest way for custom checks is. Define one custom check inside WATO.
Inspect the syntax (is different from old legacy checks) and transform your old checks to the new syntax.
I have done such a thing some years ago and it is no nice work :slight_smile:

Thank You. Yes, this would be ok for me. My problem is that I dont have (or cannot find, maybe I’m blind) this option in WATO? Can you just tell me where should i look for this Custom Checks option?
I think I’ve overclicked whole WATO and didn’t have any luck with this :frowning:

Still no luck in finding any option to actually add any custom service/script in WATO.
is it possible that this is unavailable in raw version?
Or maybe I should not look in GUI, or just create scripts and upload them into some plugin directory ?

You need to go the the “Active checks” -> “Classical active and passive Monitoring checks”
Define a rule there and then it should be possible for you to adapt this for your old checks.

Thank You. Found it.
I’ll try to adapt it. Thanks.