Problem with discovery - vanished service can't be monitored again

Hello, everyone.
I’m using Check_MK with version 2.0.0p4 CRE
My agents is updated to Version: 2.0.0p4

At first, I have problem with netifaces_rbl plugin - It simply asked me to perform a manual migration as it described in werk#10601.
So, to spend less time on this, I’ve decide to use this package from Checkmk Exchange.

But after that I’ve expirience some weird behavior of my checkmk. Let me describe:

  1. I’ve got discovery rule in ruleset RBL, which I didn’t change all that time
  2. After I’ve done with reinstall of netifaces plugin, it works well and check showed me OK status
  3. Check_MK Discovery marked that check like vanished service, and when I was trying to fully rediscover services of host, Discovery still show me my check as vanished service

What I’m already trying and it didn’t work:

  1. $ cmk -II
    It remove my check from var/check_mk/autochecks/ conf and I can’t monitore It. I consider this as “didn’t work” for me
  2. $ cmk --flush
    $ cmk -II
    Same result
  3. I delete previous rule, apply changes and create new. Rediscover with gui and got same result.

If you know where I can find discovery configs on my master, please, let me know. It would help me to better understand how discovery works in checkmk, since there’s no better explanation in docs right now

The netifaces_rbl check for 2.0 has changed its behaviour a little bit.

It now needs a discovery rule to create the service checks.

1 Like

Thanks for reply!
Yes, I got this discovery rule. But, discovery cannot find service on my agent.
Am I missing something on agent?

Your check didn’t work at all

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed. Contact an admin if you think this should be re-opened.