Report: get rid of "All Services"


I am trying to get my BI-Aggregation into a nice Report. But fail. The manual tells me, that many views have a “Add to Report” button:

(picture from the manual itself)

Indeed I found this button and so I built my nice table and it looks like this:

Having been unable to produce any useful report manually, I found the promised button and added my view to my Report.

Then looking at my report I find this:

Thirty-nine (!) pages of tables and under Chapter 2: the table I wanted.

I have read the manual, looked at all the options, played with any of them which looked interesting and failed.

Any idea how to get rid of the host-tables and only keep the availability-table?

chris :slight_smile:
PS: new users may only post 1 image, so this got split up into three posts because I really wanted you to see what I see.

do you search Info`s like this ???:

another idea is:

add the snapin for Reports:



create a copy of the report


edit the copy

make your settings and go to elements


edit Content Elements


and ajust the Options

Hello and thank you, Bernd.

The TruePath blogpost looks exactly like what I wanted. But after following all the steps, I still end up with a 40 page PDF. 39 of them still have the unwanted node-service-stats of ALL hosts.

I have no idea where those host-stats come from. I agree that the options should be able to change that outcome, but I would not know which option - maybe even a combination.

I wonder if my cmk-server has an old and buggy version or the dialogs have some funny defaults set that got messed up during an upgrade. I don’t know.
Which is why I asked for the forum’s kind help.

Have you ever seen this output? What would usually generate it and how to get rid of it?

Thank you again.
chris :slight_smile:

define a servicegoup with just the service You want in the Report and activat this also:


Thank you.

However, that is the point: I want ALL services. If anything goes off course, I need to know.
But the best I can currently manage is getting some hosts. Zero services so far.

after re-reading I understood your problem and I had the same.
My workaround was to build a separated report for all services that I knew that were on the BI.

I give up. I will live with the fact, that my report is 90% full of things that I don’t want to see.

Thanks for your time!
Chris :slight_smile: