I currently teach our website adminisration tool to talk to CMK. However, I noticed two things:

  • Getting a rule list requires ruleset_name but creating requires ruleset. The name is not consistent?
  • Iam not able to patch an existing rule? I always have to delete and add a new one if some tiny detail changed?

Is that correct?


Ah, just found: Edit Rules via checkmk REST API (checkmk Version 2.1)

So, I just want to leave the rulese vs ruleset_name feedback here :slight_smile:

Hi Robin, can you give a small code example of what you mean exactly?

Sure :slight_smile:


The name could be the same, or did I miss something?

Now I got you!

Okay, so we are not facing some functional issue or bad inconsistency, but rather a minor inconsistency.
I will pass that on to the developers, but as this would be a breaking change, I am afraid we might keep it like that.
After all, it is a minor inconvenience, right? :slight_smile:

Yep :slight_smile: Nothing special.

Yes, since it is out in prod, I assumed this.