Rule for Discovering specific Filesystem Drives on Windows Server does not work

Hello there,

I’m brand new to the checkMK world, so please be patient with me :). I already searched for similar topics, but didn’t get the answer I need.
We installed our checkMK virtual appliance a few weeks ago and it works like a charm.

But I have one issue with some windows terminal servers. The service discovery rule for filesystems does not only find the system drives, but also every userprofile, that is logged on (we are using roaming profiles). If a user is moved to another terminal server in our cluster, the service is vanished. This happens like 20 times a day with different user profiles on different terminal servers.

I tried to create a specific rule for these terminal servers, so that ONLY “C:/” oder “D:/” will be discovered. I used a regular expression to do that. It looks like this:

I guess I messed up the expression. I thought the dollar sign would force the rule to ignore everything after C:
The Services beeing discovered and vanished a few hours later look like this:
2021-09-15 09_33_30-Window

My question is how can I force checkMK to NOT monitor these “sub” filesystems for our terminal cluster?

Thank you very much for any responses :slightly_smiling_face:

Greetings from Germany
Alex

Your screenshot shows the disabled services section of the service configuration.
This looks ok.

It is better to define a rule for the ignored services.
This looks like the following example.

Disabled Services rule

1 Like

Yeah, my screenshot was from the disabled section because I disabled the services manually. But they would show up everytime a new mount was found as a new discovered service (with the new username).

Now I added the regex value “Filesystem C:/Users.*” to the disabled services rule and it works now!
Thank you very much for this hint! Helped a lot!

And I just discovered, that by using this way I can disable specific services for all hosts at once instead of creating host specific rules all the time *facepalm

Can’t thank you enough!!