Service Check Interval

Dear Community

this may sound like a simple beginner problem, but i don’t find a solution.

i’ve created a dynamic configuration for all vm’s with the “Check state of VMWare ESX via vSphere” and set up the vCenter as a host system without the checkmk plugin.

After some time, all of the clients run into a stale state, telling me that they didn’t got any new information since the last check.

Can someone tell me, where do i configure the check intervall?

Which check interval do you like to change or check? The check of vSphere Host, vSphere service or the VM services for your piggyback data?

The data are provided from the vSphere via the special agent for vSphere is caching the piggyback data, maybe there is a problem.

i want to change the interval of the piggy data, that gets collected.
I cannot say if they are checked at all because i can’t find any settings for it.

EDIT: I found a rule called “Normal check interval for host checks”, maybe setting this rule will help

Have you defined any rule influencing the check interval for your vsphere host/service?
The rule names are:
Normal check interval for service checks
Normal check interval for host checks

If it’s not the case, can you check if the agent of your vSphere host delivers information to VMs? You can check for the section <<<esx_vsphere_vm>>>. And can you take a screenshot of you rule Check state of VMWare ESX via vSphere, but please censor all sensitive data.

i’m sorry for the bad explanation.

This picture shows the output of the special agent for the vCenter

Rules:
Service check interval - 1min
Host check interval - 5min
Service discovery - 1min

I set all of these, because i don’t know which of this one will trigger the lookup process (picture).
After waiting for the next alert, i noticed that noone of this causes a new scan.

EDIT: The problem lies in the datasource rule which doesn’t starts automatically

Ok, just to set things right and simple:

The checkmk server uses his special agent to get information from the vCenter (no normal agent installed).
The dynamic configuration is set to 1 min lookup, which means (i guess) that he looks into his filesystem for new piggybacked files, but doesn’t activly contact the vCenter, he just updates the server services he found in the files.

I have now three problems.
The first is, that my piggybacked hosts run into a stale state after 5 mins, is this configureable?
The second, if i press on “full scan” at the vCenter to trigger the special agent, he starts collecting new files and instantly all of my hosts looses their stale state BUT where can i set this scan with a schedulded time and third, why does all of these hosts get updated if my dynamic configuration is set with a time of 2 hours (what time do i set really at the dynamic configuration)?

I’ve read the whole article from checkmk (https://checkmk.com/cms_dcd.html) up and down, but didn’t find a solution.

The vCenter host needs to have a service monitored.
In my case, i didn’t enabled any of the found services.

After setting up at least one service, the datasource agents started to periodically collect the vCenter data.