Ssh reverse tunnel no work

Hi all,

I am using ssh reverse tunnel to connect a check_mk master and a slave. The connection is successful:

Master <—> Slave
16557 <—> 6557

MASTER SERVER:
tcp 0 0 127.0.0.1:16557 0.0.0.0:* LISTEN

However it does not connect. I am using CRE 1.6.0p14

image

Someone else happens the same, Thanks!!!

I found the error.

If at LIVESTATUS_TCP_ONLY_FROM = 0.0.0.0 :: / 0, it works.
1596145882

If it is any IP it does not work.
1596149901

If LIVESTATUS_TCP_ONLY_FROM has been changed, 0.0.0.0 :: / 0 cannot be reconfigured because it says it is an invalid value. So you can’t connect with livestatus.
1596148275 1596148285

The problem is only the IPv6 address there in the configuration. I think it is only a problem inside the CMK config command line tool. If you use the site configuration inside WATO - Global settings - site management, then you can also insert IPv6 again there.

2 Likes

thanks andreas-doehler, i will try inside WATO - Global,

Hi @andreas-doehler,

Insert IPv6 inside WATO - Global settings no work. Is it a bug?

It’s only solved edit file:

vim /omd/sites/cmk_inerza/etc/mk-livestatus/xinetd.conf

configure the IP address(es) of your Nagios server here:

    only_from       = 0.0.0.0 ::/0

Yes your right then it is a bug if it brings the same error here.