Trying to monitor my UPS

Hello,

I’m using Checkmk 1.6.0p19 raw edition.

I’m trying to add my Eaton UPS via SNMP monitoring. I added the UPS With “no agent, all configured special agents” and added the SNMP information. When I test SNMP, everything seems to work.

The problem is that the ups plugins (like ups_in_voltage) don’t get discovered for this host.

When I “force” to check the plugin with cmk, the service gets discovered and I can see the correct data in the GUI, but they are shown as “vanished”.

Does anybody has an idea where to look ? Why doens’t the GUI wants to use the ups plugins?

$ cmk --checks=ups_in_voltage -vvI nobreak.mysite.local
Discovering services on: nobreak.mysite.local
nobreak.mysite.local:

  • FETCHING DATA
    [snmp] No persisted sections loaded
    [snmp] Not using cache (Don’t try it)
    [snmp] Execute data source
    [snmp] ups_in_voltage: Fetching data
    Running ‘snmpwalk -v3 -l authNoPriv -a md5 -u mysite -A myupspass -m “” -M “” -Cc -OQ -OU -On -Ot 10.10.10.70 .1.3.6.1.2.1.33.1.3.3.1.3’
    [snmp] Write data to cache file /omd/sites/mysite/tmp/check_mk/data_source_cache/snmp/nobreak.mysite.local
    Try aquire lock on /omd/sites/mysite/tmp/check_mk/data_source_cache/snmp/nobreak.mysite.local
    Got lock on /omd/sites/mysite/tmp/check_mk/data_source_cache/snmp/nobreak.mysite.local
    Releasing lock on /omd/sites/mysite/tmp/check_mk/data_source_cache/snmp/nobreak.mysite.local
    Released lock on /omd/sites/mysite/tmp/check_mk/data_source_cache/snmp/nobreak.mysite.local
    [piggyback] No persisted sections loaded
    [piggyback] Execute data source
    No piggyback files for ‘nobreak.mysite.local’. Skip processing.
    No piggyback files for ‘10.10.10.70’. Skip processing.
    Loading autochecks from /omd/sites/mysite/var/check_mk/autochecks/nobreak.mysite.local.mk
  • EXECUTING DISCOVERY PLUGINS (1)
    Trying discovery with: ups_in_voltage
    Try aquire lock on /omd/sites/mysite/var/check_mk/autochecks/nobreak.mysite.local.mk
    Got lock on /omd/sites/mysite/var/check_mk/autochecks/nobreak.mysite.local.mk
    Releasing lock on /omd/sites/mysite/var/check_mk/autochecks/nobreak.mysite.local.mk
    Released lock on /omd/sites/mysite/var/check_mk/autochecks/nobreak.mysite.local.mk
    SUCCESS - Found no new services, no new host labels

The problem is the value of the OID .1.3.6.1.2.1.1.2.0
If the value is one of the following it would be discovered.

    '.1.3.6.1.4.1.232.165.3',
    '.1.3.6.1.4.1.476.1.42',
    '.1.3.6.1.4.1.534.1',
    '.1.3.6.1.4.1.935',
    '.1.3.6.1.4.1.8072.3.2.10',

It will also work if this OID starts with

    '.1.3.6.1.2.1.33',
    '.1.3.6.1.4.1.5491',
    '.1.3.6.1.4.1.705.1',
    '.1.3.6.1.4.1.818.1.100.1',

can you have a look at your device OID?
If your OID is missing in the two lists it can be extended.

The important file is the “ups_generic.include” inside the “~/share/check_mk/checks/”
If you extend the list you should copy this file to “~/local/share/check_mk/checks/”.

For Eaton devices there is also some extra checks like the environment check shown in your screenshot.
There you find the OID lists inside the checks. Same procedure copy the original checks to the “local” structure and extend the lists.

Thank you !

The strange thing is that I tried everything many times, but after I specified the plugin in the command prompt, the services got added in the GUI the next day automatically ! So this problem is solved, although I don’t know exactly what caused it.

I still have one problem now, I have also used the plugin ups_out_load. I see the message “Found configured rules of deprecated check group “ups_out_load”. These rules are not used by any check. Maybe this check group has been renamed during an update, in this case you will have to migrate your configuration to the new ruleset manually. Please check out the release notes of the involved versions. You may use the page “Deprecated rules” in WATO to view your rules and move them to the new rulesets.

But when I go to WATO, Rule-Based Configuration of Host & Service Parameters, Deprecated Rulesets and i search for everything, I don’t see any deprecated rules…