Turning down the number of helper processes on a site that won't start (because it is starting too many helper processes)

I’ve got a very large site that I’m trying to clone (via backup restore) on a test server (with less RAM and CPU). Being a large site, it’s configured to start many helper processes, which entirely swamps this poor machine.

var/log/cmc.log:2022-11-22 17:20:18 [5] [Check_MK helper pool] started 200 Check_MK helpers in 12826.5 ms

So I found and updated the relevant config lines with smaller numbers

etc/check_mk/conf.d/wato/sitespecific.mk:cmc_cmk_helpers = 20
etc/check_mk/conf.d/wato/global.mk:cmc_cmk_helpers = 10
etc/check_mk/conf.d/wato/global.mk:cmc_real_time_helpers = 10
etc/check_mk/conf.d/wato/global.mk:cmc_check_helpers = 15

and yet

var/log/cmc.log:2022-11-22 18:26:51 [5] [Check_MK helper pool] started 200 Check_MK helpers in 11002.3 ms

Evidently this setting is saved somewhere else. I found the precompiled_check_config.mk by grepping for helpers but deleting that still had it starting the 200 processes.

What have I missed here? I don’t normally have to work without the web interface :frowning:

After changing the config i would do a “cmk -U” to update the running config of your system.

2 Likes

That appears to be exactly what I was missing, cheers. I don’t have to work on Checkmk without the web UI often.