Update auf 2.1.0p8 bringt einen Fehler bei

**CMK version: 2.1.0p8
**OS version: Debian Bullseye

Error message:
Traceback (most recent call last):
File “/omd/sites/RoboTum/lib/python3/cmk/gui/plugins/metrics/html_render.py”, line 733, in render_graph_content_html
graph_artwork = artwork.compute_graph_artwork(
File “/omd/sites/RoboTum/lib/python3/cmk/gui/plugins/metrics/artwork.py”, line 116, in compute_graph_artwork
curves = compute_graph_artwork_curves(graph_recipe, graph_data_range)
File “/omd/sites/RoboTum/lib/python3/cmk/gui/plugins/metrics/artwork.py”, line 261, in compute_graph_artwork_curves
rrd_data = rrd_fetch.fetch_rrd_data_for_graph(graph_recipe, graph_data_range)
File “/omd/sites/RoboTum/lib/python3/cmk/gui/plugins/metrics/rrd_fetch.py”, line 26, in fetch_rrd_data_for_graph

Output of “cmk --debug -vvn hostname”: (If it is a problem with checks or plugins)

Dumme Frage - wo kommt der Fehler?

After upgrade to 2.0.0p27 I have the same error in default dashboard:

Having the same error in a fresh install of Checkmk Free Edition 2.1.0p9

I already filed a ticket. Will be solved in next release.
The root cause is that no checkmk server is in the monitoring.

1 Like

Ich habe den Fehler auch in dem neueste p9er - Release:

Cannot create graph
Traceback (most recent call last):
File “/omd/sites/xxxx/lib/python3/cmk/gui/plugins/metrics/html_render.py”, line 733, in render_graph_content_html
graph_artwork = artwork.compute_graph_artwork(
File “/omd/sites/xxxx/lib/python3/cmk/gui/plugins/metrics/artwork.py”, line 116, in compute_graph_artwork
curves = compute_graph_artwork_curves(graph_recipe, graph_data_range)
File “/omd/sites/xxxx/lib/python3/cmk/gui/plugins/metrics/artwork.py”, line 261, in compute_graph_artwork_curves
rrd_data = rrd_fetch.fetch_rrd_data_for_graph(graph_recipe, graph_data_range)
File “/omd/sites/xxxx/lib/python3/cmk/gui/plugins/metrics/rrd_fetch.py”, line 26, in fetch_rrd_data_for_graph

Short update to this graph error message.
If the CMK host itself is not monitored with an actual agent then you will have this error.
The important service needed for this graph to work is the “Site <sitename> statistics” service.

1 Like