VMware ESXi mit eigenem Skript überwachen

Hallo,

ich versuche für meinem ESXi im Homelab einen eigenen Check zu schreiben. Dieser Beitrag war sehr hilfreich, leider komme ich an einer Stelle nicht weiter.

Was ich habe wären ein funktionsfähiges Skript und die SSH Integration auf meinem cmk Server; Ob der Output „cmk ready ist“ weiß ich noch nicht :smile:

OMD[cmk]:~$ ssh -T root@host -i /opt/omd/sites/cmk/.ssh/id_rsa
<<<local>>>
ESXi NVMe Samsung_SSD_980_PRO_1TB
count1=47|count2=58;68;75
TemperatureWarning:false
HealthStatusOK

Aber an welcher Stelle oder mit welcher Regel platziere ich die auszuführende Befehlszeile:

ssh -T root@$HOSTNAME$ -i /opt/omd/sites/cmk/.ssh/id_rsa

Alle Versuche waren leider nicht erfolgreich, im verlinkten Beitrag wird von „Classical active and passive Monitoring checks“ gesprochen und die finde ich wo genau?

Wer kann mich hier bitte unterstützen?

Der Aufruf selbst kommt in die Regel
“Individual program call instead of agent access”
und der Output muss noch etwas anders formatiert werden, damit er einem Local Check entspricht.
So wie in dem verlinkten Beitrag sollte es dann funktionieren.

Im SSH Aufruf brauchst den Key nicht mit angeben wenn dieser, wie in deinem Fall, innerhalb der Site mit einem “Default” Namen vorhanden ist. Es sollte auch ein “ssh -T root@host” ausreichen.

Mhh, das habe ich bereits versucht und es passiert nichts.

dann am Host zugewiesen


Auch wenn ich die Regel über Explizite Hosts zuweise, bekomme ich keine Reaktion.

OMD[cmk]:~$ cmk -nv --debug --checks=local esx
WARNING: '--checks' is deprecated in favour of option 'detect-plugins'
Checkmk version 2.0.0p25
+ FETCHING DATA
[PiggybackFetcher] Execute data source
No piggyback files for 'esx'. Skip processing.
No piggyback files for 'ip'. Skip processing.
+ PARSE FETCHER RESULTS
Received no piggyback data
execution time 0.0 sec | execution_time=0.010 user_time=0.010 system_time=0.000 children_user_time=0.000 children_system_time=0.000 cmk_time_agent=0.010

Auch wenn das Skript “noch” nicht stimmt müsste doch hier was passieren?

Ja, stimmt - wollte es im Container nur immer mit angeben.

Ich habe meine Abfrage jetzt mal auf einem Linux Client mit Agent (lokalen Check) optimiert :smiley:

Habe natürlich den Checkmk agent nicht aktiviert in den Host Eigenschaften … Jetzt läufst wie gewünscht!