VMWare server appliance services

Hi all,

Can anyone help this newbe (me) with the following.
I want to check the services of our vcenter server applicance.
And than esspecialy the VMware Appliance Monitoring Service.

Every manual what i found is telling how i’m monitored the vsphere, but not the appliance services monitoring. Or i’ve got reading it false.

Kind regards,

Marco Huiting
Systemadministrator Hosting environment

Hello Marco, you can find a solution here -> https://exchange.checkmk.com/p/vmware-vcsa-services-healthstatus-api-monitoring
This is a check - plugin, you can use for checking the vcsca vcenter services. The check will use Data received from the vCSA / vCenter API. The only thing you must know, the user must have enough access rights and the vCenter - Version shoud be >= 6.7., These things i´ve documented in the check plugin.
last week i test out all the checks with vCenter 7.0. Works fine, too.

Hope, this will help you.

Greetings from Dortmund

Thomas Sielaff

Hello Thomas,

Thanks for the response. This is the solution what i was looking for.
The only thing wat i have, is that the state is critical. (CRIT - [special_vcsa_services] Version: 1.0.3, OS: vCenterAPI, Got no information from host, execution time 1.2 sec)
When i download the agent output, I see the services.
What can i do wrong? Is it that we don’t have certificates? (ssl certificate validation is off)

The vsphere api explorer is getting info back.

I hope that there’s an solution. This is exactly what i need.

Greets from the netherlands (30 km from emmerich)

Marco Huiting

Hello Thomas,

It’s working. The applmgmt must be started. This was exactly why i want to monitor this.

Thanks for the solution and the help.

Kind regards,
Marco Huiting

Try to use “cmk -Dvv hostname” on the console. Then you will see the output and the command line, which is called by the data source. "/omd/sitename/…-username … - password… and so on.
Then copy only this line again to execute it on the command - line. Then look, what will happen. The most errors will occure, if you don´t have the correct permissions. I know, that you must have a user, which has the role such named like “SystemConfigManager” or “SystemConfigAdministrator” or such like this.
This you wil have to configure in the vSphere - GUI. We use an local - User. e.G. “my_special_user@localos” and this user has the correct privileges. I needed such a long time with “try and error” to find out to fix this problem.
For using or disabling SSL, please select “disable ssl certificate verification” in the datasource programm.
For testing, you can try to only select “use all datasources”.
Then on the cli try to execute manually, like i described before. Try to use the ip -address on the command - line. But note, you can only be sure, to get the correct information, and that the check will deliver the correct data, when you

  • first login on the vsphere GUI (with the user, you will late use in check_mk!!!) >> vcenter API
    Then you look into the section vcenter/vcenter-services (don´t know the exact address now, but you can see the url in the check, when you want to know it).
    Then look for the details and press “Try it out”. Only - only - only in the case, you will receive date, you can be sure, that all will be fine, when you will execute the check later. That´s why you´ve logged in, with such that user, which is not the administrator. Most people do forget this important thing.
    The check is running 2 times against the API. First time to get a session - id. second - time, while using these session - id, a request will try to receive the data you need. Hope, this will help you?? Greetings, Thomas

Fine, that makes me happy. next time. if you need for example a check to find out the vSphere - Cluster - Health Check (HA-config/DRM-config/-Status) let me know. I already have a solution. I need only more time to clean the code. But in our prod - environment, this is still running.

Greetings, Thomas

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.