Agent service restart

CMK version: 2.0.0p11
OS Version Amazon Linux 2

Hi All,

I find in the log messages this message that repeats with a frequency of 60 seconds

systemd: Starting Checkmk agent (checkmk_ip:port)…
systemd: Started Checkmk agent (checkmk_ip:port).

Maybe is this related to the introduction of the new service check-mk-agent-async documented here ?

check_mk_agent: Fix issues with systemd (checkmk.com)

Thanks in advance,
mau

I’m connecting to the checkmk agent via ssh, not via systemd, so I might be totally wrong on this, but:

AFAIK you have a “check_mk.socket” systemd service which is just listening on the port for incoming connections and only then starts the real agent. So having the agent run (start) every 60 seconds sounds like the normal and expected behaviour to me.

Hi Martin,

Thank you for your reply.
I thought the same so I put a Rule of the type “Normal check interval for host checks” at host level with check interval=5 minutes , but nothing is changed . Am I modifying the wrong parameter ?
Thanks in advance,
mau

Hi All,

I have discovered that the rule that suits my needs is “Normal check interval for service checks”