Agent updater don't start on hardened Linux machines

CMK version:
2.0.0p27
OS version:
SLES 12SP5 // SLES 15SP3
Error message:
After start of cmk_update_agent →
Error while loading shared libraries: libz.so.1: failed to map segment from shared object: Operation not permitted

Cause:
/tmp is a fileystem what mounted with “noexec” flag for security reason

Workaround:
remount the /tmp with exec priviledge

mount /tmp -o remount,exec

But this is no real solution as the noexec is set as a security setting.
Suggestions for solutions are welcome.

With the ruleset “Installation paths for agent files (Linux, UNIX)” you can set individual TMPDIR variables for the Linux agents. The content of this variable will be used instead of /tmp.

1 Like

Thanks one option more that i not used before :slight_smile:
Only one addition for the registration you need to manually export the TMPDIR variable.

1 Like

This should be filed as a bug report.

2 Likes