Appliance verliert Netzwerkkonfiguration (Bonding)

Seit wir unsere CheckMK Appliance von 1.4 auf 1.5 aktualisiert haben, verliert der Server nach jedem Neustart das Netzwerk.
Es ist ein Bonding, bestehend aus den beiden ersten Interfaces, konfiguriert. Nach dem Neustart muss lokal auf den Sever angemeldet werden und die “einfache” Netzwerkkonfiguration eingestellt werden. Erst dann dann kann via Netzwerk eingeloggt und das Bonding wieder erstellt werden.
Gibt es eine Möglichkeit, dass die Bonding-Konfiguration nach dem Neustart nicht verloren geht?

Hi,

eventuell liegt das an einem Problem mit wechselnden Netzwerk Interface Namen.
Hast du schon auf 1.5.2 aktualisiert, da gibt es einen Bugfix.

Viele Grüße
Andre

Ja, wir haben bereits 1.5.2 im Einsatz.

Hallo,
ändert sich ggf. was an der Konfig der virtuellen Interfaces auf Hypervisor-Ebene?
Neue Mac-Adressen z.B…
Gruß

Die Appliance ein physischer Server (Check_MK rack1 Mark III) von Huawei. Die MAC-Adresse ändert nicht.

Was wir mit “dmesg” festgestellt haben, dass die Interface-Namen von “eth#” nach “enp2s0f#” umbenannt werden.

Das kann man zwar fixen aber da muss cmk liefern.
Das Gerät wird ja unter Wartung sein.
Gruß

Hi,

dann ist das Problem eventuell nicht zu 100% gelöst.
Ich würde beim Hardware Support ein Ticket aufmachen…

VG
Andre

Hallo Andre,
die Hardware wird sich doch nicht ändern.
Ich kenne diese Effekte nur wenn das OS eine Macke hat.
Was kann der HW Hersteller deiner Meinung nach machen?
Gruß

Der HW-Support hat gemeldet, dass er nicht zuständig ist:

Da dieses Problem allerdings erst nach einem Firmware-Update aufgetreten ist, gehen wir von einem Problem in der Firmware aus. Für diese ist tribe29 direkt zuständig.

Deshalb habe ich es als Bug (Feedback) gemeldet.

Hi,

das geht in den Bereich hier, klar ist das eine Konfiguration im Betriebssystem…

Ich war bei Hardwarenahen Problemen davon ausgegangen, dass das auch der HW Support macht, aber OS liegt dann anscheinend voll bei Tribe29.

Ja, das tönt nach einer Lösung für unser Problem. Wir haben jedoch rack1 im Einsatz. Hoffentlich wird es dafür auch bald ein Patch geben.

https://www.xmodulo.com/change-network-interface-names-permanently-linux.html
aber das kann auf einer Appliance nicht dauerhaft die Lösung sein.
Gruß

Workaround:
Wir haben das im Moment so gelöst, dass Fehler beim Starten des Netzwerkes ignoriert werden und folgendes File entsprechend angepasst: /usr/lib/systemd/system/ifupdown-pre.service
So startet das Bonding nach dem Reboot.

Checkmk ist ja cool wenn es funktioniert, aber wenn es nicht funktioniert ist man echt verloren. Feedback hat das Ticket geschlossen mit Verweis auf die Lifecycle Policy. Ja Checkmk 1.5 ist nicht mehr Supportet, aber es geht um die Appliance 1.5 die ist scheinbar so neu das Feedback noch nichts davon gehört hat.
<RANT/>

Gemach,
Fehler passieren und es wird viel zu warm um sich aufzuregen.
Gruß

1 Like