Automatic Agent Update : Version: 2.1.0p16, OS: windows, Update error: The agent updater is not registered at the deployment serverWARN, No successful connect to server yetWARN, Agent plugins: 1, Local checks: 0

CMK version:
2.1.0p16

OS version:
centos8

Error message:

Hello ,

I am unable to finish the registration process of the agent on checkmk servers .
every time I get this error :

Would appreciate some help -

Thanks

AgentUpdate: last_check None last_update None aghash None pending_hash None update_url http://xxx/xxx/check_mk error The agent updater is not registered at the deployment server

cmk-update-agent.state
{‘last_error’: ‘The agent updater is not registered at the deployment server’}

cmk-agent-ctl.exe status returns :

Version: 2.1.0p16
Agent socket: operational
IP allowlist: any

Connection: server:8000/site
UUID: xxxxx
Local:
Connection type: pull-agent
Certificate issuer: Site ‘site’ local CA
Certificate validity: Tue, 22 Nov 2022 14:18:11 +0000 - Sun, 25 Mar 3021 14:18:11 +0000
Remote:
Connection type: pull-agent
Registration state: operational
Host name: server-name

2022-11-22 15_33_08-Minusines IT Monitoring - Edit rule_ Agent updater (Linux, Windows, Solaris)

Can you please provide the output if you do a “cmk-update-agent register”.
The “cmk-agent-ctl” has nothing to do with the updater function of the agent.

Hi ,

I am on a Windows Host and I am not able to perform this command as the executable is not present .
The only similar file I have is a python file
C:\ProgramData\checkmk\agent\plugins\cmk_update_agent.checkmk.py

Thanks .

Hello minusineslu,

with the new agents (since 2.0) the update registration changed.
You should call
C:\Program Files (x86)\checkmk\service\check_mk_agent.exe" updater register
It’s described in the documentation here: Automatic agent updates - Distribute agents and plug-ins automatically

BR
Daniel

1 Like

I wrote this as the OS given in the first post was CentOS8.

Hi ,

I found my mistake.

The Authentication of my automation user was set to :Automation secret for machine accounts
where I had put a secret .

I had previously already tried this command with the automation user and somethimes no feedback and other times I got cannot authenticate.

I changed the setting to password and now it is working .

Thanks for the support.

Automation users should not have a password set.
At the command line to setup the agent updater you have the two options “-S” to provide a secret and “-P” to provide a password. The -P option should be used if you use a normal user account and the -S for automation accounts.

Hi ,

ok , I will remove password and enable secret.
and I will retest on the host.

Hi Andreas ,

Yes this did work with the command
check_mk_agent.exe updater register -S

1 Like