"Best Practices" rule for filesystem thresholds with magic factor broken?

CMK version: 2.1.0p18 CRE
OS version: Ubuntu 20.04 and 22.04

Error message: An Empty Value is not allowed here.

Hi all,

I wanted to set up a general rule regarding Filesystem thresholds to use the Magic Factor, as described in Best Practices, Tips & Tricks No. 5 but ran into an issue configuring the rule. I am not entirely sure if I missed anything or there have been changes with one of the latest update, due to witch this rule cannot be configured as before.

From what I understand from the Tip, the rule is configured as a general rule matching parameters for filesystem used space levels. But I have two parameters in the latest Version (2.1.0p18 CRE) which seem to be different from what is also shown in the screenshot in the document. There are both a checktype and a mountpoint parameter, which I cannot leave empty and thus not allowing to set this up as a general rule. the checktype of all choices is even preset to a Fortinet Sandbox and has no option to leave it blank (not that I know if that actually would make any difference or if that one has some sort of influence at all.)
But the error is about giving a mount point, which would defeat the idea to have this work for all kind of mounted windows as well as Linux volumes. Using some sort of wildcardseems not to work either (or I did not guess the correct syntax)

Anyone any ideas if it is either not possible anymore due to changes or I simply (most likely) overlooked something?

I think you have opened the ruleset iin the “Enforced Services” section of setup. You may want to open the normal service check parameter ruleset.

1 Like

Oh my, how embarassing. I absolutely did.

I just searched for filesystem in Rules and did not even realize this entry exists in two categories. To be honest, as nothing in that regard was mentioned in the Best Practices document I didn´t even bother to look any further after finding the first entry.

Choosing the right category made it work exactly as described.

Thanks