[BUG] Smart-Plugin can't read SAT-Devices

Hi,

I just discovered that the smart-plugin from CheckMK CEE Version 2.0.0p24 isn’t working properly at my proxmox 7.2 nodes.

Running the ‘generated’ $CMD on the command line I get following output:

root@server:/tmp# smartctl -v 9,raw48 -d ata -A /dev/disk/by-id/ata-INTEL_SSDXXXXX_XXXXXXXXXX
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.15.30-2-pve] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke, www.smartmontools.org

Read Device Identity failed: Invalid argument

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

Running the $CMD without the parameter ‘-d ata’ it works like charm.
I ran

root@server:/tmp# smartctl -d test
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.15.30-2-pve] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke, www.smartmontools.org
/dev/disk/by-id/ata-INTEL_SSDXXXXX_XXXXXXXXXX: Device of type 'scsi' [SCSI] detected
/dev/disk/by-id/ata-INTEL_SSDXXXXX_XXXXXXXXXX [SAT]: Device open changed type from 'scsi' to 'sat'
/dev/disk/by-id/ata-INTEL_SSDXXXXX_XXXXXXXXXX [SAT]: Device of type 'sat' [ATA] opened

to figure out that my device is a SAT not ATA Device.

I could help myself by editing the $CMD in Line 161 to:

CMD="smartctl -v 9,raw48 -A $D"