CMK version:
Enterprise Edition 2.1.0p24
Error message:
[special_3par] Agent exited with code 1: Wrong status code: 405. Expected: 201CRIT, execution time 0.5 sec
Output of “cmk --debug -vvn hostname”: (If it is a problem with checks or plugins)
Calling: /omd/sites/[sitename]/share/check_mk/agents/special/agent_3par ‘–user’ ‘checkmk’ ‘–password’ ‘password’ ‘–port’ 443 ‘–no-cert-check’ ‘192.168.1.2’
[cpu_tracking] Stop [7f01a68599a0 - Snapshot(process=posix.times_result(user=0.0, system=0.010000000000000009, children_user=0.24, children_system=0.01, elapsed=0.5400000028312206))]
+ PARSE FETCHER RESULTS
Source: SourceType.HOST/FetcherType.PROGRAM
→ Not adding sections: Agent exited with code 1: Wrong status code: 405. Expected: 201
Received no piggyback data
Description
We integrated HPE Alletra Storage MP in our checkmk using 3par plugin. Since it is a self-signed certificate, we deactivated the SSL certification verification for plugin and got an error reporting below:
[special_3par] Agent exited with code 1: Wrong status code: 405. Expected: 201CRIT, execution time 0.5 sec
When we activated the SSL certification verification, the error message was different:
[special_3par] Agent exited with code 1: Error: HTTPSConnectionPool(host=‘192.168.1.2’, port=443): Max retries exceeded with url: /api/v1/credentials (Caused by SSLError(SSLCertVerificationError(1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1129)’)))CRIT, execution time 0.5 sec