Cannot delete time periods

Hello :slight_smile:
i just discovered that i can careate, copy and use timeperiods but not delete them.
I get this error:


This applies to all time periods
1.6p18CEE

BR Thomas

Same version, but could not reproduce this.

  • create time period
  • activate changes
  • delete time period - not used anywhere
  • ativate changes

→ works, no error.

Do you receive the error immediately when you click on delete?
Or do you first get the “are you sure” confirmation dialog? Does that dialog state that the time period is not in use?
Is the time period still in use somewhere?

Hi Martin
i discovered this today by accident and thought at first it would only apply to one rule i had just created but wanted to delete it. So not sure how long this already is.
Creation & activation: works
Copy rulez, edit parameters & activation: works.
Deletion: brings me that error instantly, i.e. no confirmation dialogue.
Error occurs whether or not timeperiod is still in use or not.

BR Thomas

I didn’t check the code, but this sounds like a problem when checking if the time period is in use.
You could create a test site on the same machine, same version and try if the error also occurs there.

Hi Martin
the test site shows no errors. Oh my, now i am screwed

BR Thomas

The Python traceback shows an error while trying to load Event Console rules. Maybe that’s a hint.

Did you disable the Event Console in that site?

Hi Robert
just tried, (didn’t work our earlier bc of business hours) but no luck.
Maybe one of the addons i installed? These are plenty and until now all worked as a charm.

BR Thomas

Hi @ll,

i debbuged that problem last week and found the cause of the issue. The bug is reported and will be fixed in 1.6p19 with the following werk:

The problem is an import in cisco_webex_teams_notifications mkp that is shipped as a checkmk extension:

/opt/omd/sites//local/share/check_mk/web/plugins/wato/webex.py
Line 11
import cmk.gui.mkeventd as mkeventd

If you remove that line or comment it out, the deletion of timeperiods should work again.

hope that helps :slight_smile:
Andre

2 Likes

Hi @aeckstein
thank you so much that solved it, although i had to remove the whole plugin, not only that particular line.
Since we have moved from Webex to MS Teams finally thats no problem anymore :slight_smile:
Thank you very much, made my week

BR Thomas