Can't install check_mk agent on host on RHEL 5.11

Hello team ,

May be this problem is not related to much to check_mk but a linux general problem with the old version .

I have an issue of our old RHEL 5 linux entreprsie sytem , I have 6 of them to monitor now

The issue is that with doing

yum install check-mk-agent-1.6.0p9-1.noarch.rpm --nogpgcheck

I have : ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by check-mk-agent-1.6.0p9-1.noarch
Complete!
(1, [u’Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum’])

I have to install : yum install rpm-devel

but no way

I know that I can install manually the agent ( check_mk_agent ) and make it just executable with xinetd config , BUT how about the automatic updates with the bakery ? That why rpm is prefereable

So I am finding the way to make it works , rpm is easy to manipulate escpecially with the bakery

Kr ,

Andry

I think the version is unsupported.
Ralf

Finally I found the solution
I ve installed manually the agent ( unzip / untar rpm ) take the check_mk_agent and copy it to /usr/bin with chmod +x
The same as the updater

Kr
Andry