Check_MK Discovery Can not load Robotmk JSON data! (json.loads())

CMK version: 2.1.0p2
OS version: windows10 client

For some reason I cannot discover the new service after loading agent for robotmk.
I see this in the host:
Check_MK Discovery Can not load Robotmk JSON data! (json.loads())

Output of “cmk --debug -vvn hostname”: (If it is a problem with checks or plugins)

<<<check_mk>>>
Version: 2.1.0p2
BuildDate: Jun 8 2022
AgentOS: windows
Hostname: support01
Architecture: 64bit
WorkingDirectory: C:\Windows\system32
ConfigFile: C:\Program Files (x86)\checkmk\service\check_mk.yml
LocalConfigFile: C:\ProgramData\checkmk\agent\check_mk.user.yml
AgentDirectory: C:\Program Files (x86)\checkmk\service
PluginsDirectory: C:\ProgramData\checkmk\agent\plugins
StateDirectory: C:\ProgramData\checkmk\agent\state
ConfigDirectory: C:\ProgramData\checkmk\agent\config
TempDirectory: C:\ProgramData\checkmk\agent\tmp
LogDirectory: C:\ProgramData\checkmk\agent\log
SpoolDirectory: C:\ProgramData\checkmk\agent\spool
LocalDirectory: C:\ProgramData\checkmk\agent\local
OnlyFrom:
<<<cmk_agent_ctl_status:sep(0)>>>
{"version":"2.1.0p2","agent_socket_operational":true,"ip_allowlist":[],"allow_legacy_pull":false,"connections":[{"coordinates":"au-ev-cmk01.domain.com:8000/eve","uuid":"4f88788d-3abe-40c6-b047-62c85c9ebb54","local":{"connection_type":"pull-agent","cert_info":{"issuer":"Site 'eveleigh' local CA","from":"Fri, 26 Aug 2022 13:39:25 +0000","to":"Wed, 27 Dec 3020 13:39:25 +0000"}},"remote":{"connection_type":"pull-agent","registration_state":null,"host_name":"support01.domain.com"}}]}
<<<wmi_cpuload:sep(124)>>>
[system_perf]
Name|ProcessorQueueLength|Timestamp_PerfTime|Frequency_PerfTime|WMIStatus
|0|13057444127814|2240829|OK
[computer_system]
Name|NumberOfLogicalProcessors|NumberOfProcessors|WMIStatus
support01|4|2|OK
<<<uptime>>>
5827059
<<<fileinfo:sep(124)>>>
1661525021
<<<winperf_phydisk>>>
1661525021.31 234 2240829
2 instances: 0_C: _Total
-36 0 0 rawcount
-34 138467552472 138467552472 type(20570500)
-34 133059986213108986 133059986213108986 type(40030500)
1166 138467552472 138467552472 type(550500)
-32 22076035161 22076035161 type(20570500)
-32 133059986213108986 133059986213108986 type(40030500)
1168 22076035161 22076035161 type(550500)
-30 116391517311 116391517311 type(20570500)
-30 133059986213108986 133059986213108986 type(40030500)
1170 116391517311 116391517311 type(550500)
-28 963439641 963439641 average_timer
-28 13114562 13114562 average_base
-26 651894683 651894683 average_timer
-26 1108696 1108696 average_base
-24 311544958 311544958 average_timer
-24 12005866 12005866 average_base
-22 13114562 13114562 counter
-20 1108696 1108696 counter
-18 12005866 12005866 counter
-16 212869200384 212869200384 bulk_count
-14 36205612032 36205612032 bulk_count
-12 176663588352 176663588352 bulk_count
-10 212869200384 212869200384 average_bulk
-10 13114562 13114562 average_base
-8 36205612032 36205612032 average_bulk
-8 1108696 1108696 average_base
-6 176663588352 176663588352 average_bulk
-6 12005866 12005866 average_base
1248 58174442404575 58174442404575 type(20570500)
1248 133059986213108986 133059986213108986 type(40030500)
1250 496693 496693 counter
<<<winperf_if>>>
1661525021.31 510 2240829
2 instances: Intel[R]_82574L_Gigabit_Network_Connection isatap.{636DB9D6-C01C-4734-91B2-5DAE6F4B7815}
-122 12569279414 0 bulk_count
-110 23801719 0 bulk_count
-244 14046731 0 bulk_count
-58 9754988 0 bulk_count
10 1000000000 100000 large_rawcount
-246 8624297617 0 bulk_count
14 14046731 0 bulk_count
16 0 0 bulk_count
18 0 0 large_rawcount
20 0 0 large_rawcount
22 0 0 large_rawcount
-4 3944981797 0 bulk_count
26 9754988 0 bulk_count
28 0 0 bulk_count
30 0 0 large_rawcount
32 0 0 large_rawcount
34 0 0 large_rawcount
1086 0 0 large_rawcount
1088 0 0 large_rawcount
1090 0 0 bulk_count
1092 0 0 bulk_count
1094 0 0 large_rawcount
<<<winperf_processor>>>
1661525021.31 238 2240829
5 instances: 0 1 2 3 _Total
-232 57640420312500 57588632656250 57607588906250 57781370781250 57654503164062 100nsec_timer_inv
-96 222300312500 283410781250 261129687500 184489218750 237832500000 100nsec_timer
-94 407873125000 398548593750 401873281250 304731875000 378256718750 100nsec_timer
-90 2404552486 1279243299 904556859 1247176556 1540561904 counter
458 7229062500 3047656250 5534218750 3368125000 4794765625 100nsec_timer
460 5290781250 2207656250 2457031250 2152343750 3026953125 100nsec_timer
1096 72600799 23100145 60503226 35049161 191253331 counter
1098 0 0 0 0 0 rawcount
1508 55841309239076 56517409704880 56529506538392 56772124326852 56415087452300 100nsec_timer
1510 58281888078 47015951984 51101785906 52855798162 52313856032 100nsec_timer
1512 55783027350998 56470393752896 56478404752486 56719268528690 56362773596267 100nsec_timer
1514 0 0 0 0 0 100nsec_timer
1516 19604400 17076257 18305548 16244195 71230400 bulk_count
1518 1825479226 398871660 101364389 420069178 2745784453 bulk_count
1520 0 0 0 0 0 bulk_count
<<<mem>>>
MemTotal: 16776164 kB
MemFree: 10983548 kB
SwapTotal: 2490368 kB
SwapFree: 1710148 kB
PageTotal: 19266532 kB
PageFree: 12693696 kB
VirtualTotal: 137438953344 kB
VirtualFree: 137438849448 kB
<<<logwatch>>>
[[[Application]]]
[[[HardwareEvents]]]
[[[Internet Explorer]]]
[[[Key Management Service]]]
[[[MicropayService]]]
[[[Security]]]
[[[System]]]
[[[Windows PowerShell]]]
<<<df:sep(9)>>>
C:\ NTFS 62333948 52712240 9621708 85% C:\
<<<checkmk_agent_plugins_win:sep(0)>>>
pluginsdir C:\ProgramData\checkmk\agent\plugins
localdir C:\ProgramData\checkmk\agent\local
C:\ProgramData\checkmk\agent\plugins\robotmk-runner.py:CMK_VERSION = unversioned
C:\ProgramData\checkmk\agent\plugins\robotmk.py:CMK_VERSION = unversioned
<<<services>>>
AJRouter stopped/demand AllJoyn Router Service
ALG stopped/demand Application Layer Gateway Service
AppIDSvc stopped/demand Application Identity
Appinfo stopped/demand Application Information
AppMgmt running/demand Application Management
AppReadiness stopped/demand App Readiness
AppVClient stopped/disabled Microsoft App-V Client
AppXSvc stopped/demand AppX Deployment Service (AppXSVC)
AudioEndpointBuilder stopped/demand Windows Audio Endpoint Builder
Audiosrv stopped/demand Windows Audio
AxInstSV stopped/demand ActiveX Installer (AxInstSV)
BFE running/auto Base Filtering Engine
BITS stopped/demand Background Intelligent Transfer Service
BrokerInfrastructure running/auto Background Tasks Infrastructure Service
Browser stopped/disabled Computer Browser
bthserv stopped/demand Bluetooth Support Service
CDPSvc running/auto Connected Devices Platform Service
CertPropSvc running/demand Certificate Propagation
ClipSVC stopped/demand Client License Service (ClipSVC)
COMSysApp stopped/demand COM+ System Application
CoreMessagingRegistrar running/auto CoreMessaging
CryptSvc running/auto Cryptographic Services
CscService stopped/disabled Offline Files
DcomLaunch running/auto DCOM Server Process Launcher
DcpSvc stopped/demand DataCollectionPublishingService
defragsvc stopped/demand Optimize drives
DeviceAssociationService stopped/demand Device Association Service
DeviceInstall stopped/demand Device Install Service
DevQueryBroker stopped/demand DevQuery Background Discovery Broker
Dhcp running/auto DHCP Client
diagnosticshub.standardcollector.service stopped/demand Microsoft (R) Diagnostics Hub Standard Collector Service
DiagTrack running/auto Connected User Experiences and Telemetry
DmEnrollmentSvc stopped/demand Device Management Enrollment Service
dmwappushservice stopped/demand dmwappushsvc
Dnscache running/auto DNS Client
dot3svc stopped/demand Wired AutoConfig
DPS running/auto Diagnostic Policy Service
DsmSvc stopped/demand Device Setup Manager
DsSvc running/demand Data Sharing Service
Eaphost stopped/demand Extensible Authentication Protocol
edgeupdate stopped/auto Microsoft Edge Update Service (edgeupdate)
edgeupdatem stopped/demand Microsoft Edge Update Service (edgeupdatem)
EFS stopped/demand Encrypting File System (EFS)
embeddedmode stopped/demand Embedded Mode
EntAppSvc stopped/demand Enterprise App Management Service
EventLog running/auto Windows Event Log
EventSystem running/auto COM+ Event System
fdPHost stopped/demand Function Discovery Provider Host
FDResPub stopped/demand Function Discovery Resource Publication
FontCache running/auto Windows Font Cache Service
FrameServer stopped/demand Windows Camera Frame Server
GoogleChromeElevationService stopped/demand Google Chrome Elevation Service (GoogleChromeElevationService)
gpsvc running/auto Group Policy Client
gupdate stopped/auto Google Update Service (gupdate)
gupdatem stopped/demand Google Update Service (gupdatem)
hidserv stopped/demand Human Interface Device Service
HvHost stopped/demand HV Host Service
icssvc stopped/demand Windows Mobile Hotspot Service
IISADMIN running/auto IIS Admin Service
IKEEXT running/auto IKE and AuthIP IPsec Keying Modules
iphlpsvc running/auto IP Helper
KeyIso running/demand CNG Key Isolation
KPSSVC stopped/demand KDC Proxy Server service (KPS)
KtmRm stopped/demand KtmRm for Distributed Transaction Coordinator
LanmanServer running/auto Server
LanmanWorkstation running/auto Workstation
lfsvc running/demand Geolocation Service
LicenseManager running/demand Windows License Manager Service
lltdsvc stopped/demand Link-Layer Topology Discovery Mapper
lmhosts running/demand TCP/IP NetBIOS Helper
LSM running/auto Local Session Manager
MapsBroker stopped/auto Downloaded Maps Manager
MozillaMaintenance stopped/demand Mozilla Maintenance Service
MpsSvc running/auto Windows Firewall
MSDTC running/auto Distributed Transaction Coordinator
MSiSCSI stopped/demand Microsoft iSCSI Initiator Service
msiserver stopped/demand Windows Installer
NcaSvc stopped/demand Network Connectivity Assistant
NcbService running/demand Network Connection Broker
Netlogon running/auto Netlogon
Netman running/demand Network Connections
netprofm running/demand Network List Service
NetSetupSvc stopped/demand Network Setup Service
NetTcpPortSharing stopped/disabled Net.Tcp Port Sharing Service
NgcCtnrSvc stopped/demand Microsoft Passport Container
NgcSvc stopped/demand Microsoft Passport
NlaSvc running/auto Network Location Awareness
nsi running/auto Network Store Interface Service
PcaSvc running/auto Program Compatibility Assistant Service
PerfHost stopped/demand Performance Counter DLL Host
PhoneSvc stopped/demand Phone Service
pla stopped/demand Performance Logs & Alerts
PlugPlay running/demand Plug and Play
PolicyAgent running/demand IPsec Policy Agent
Power running/auto Power
PrintNotify stopped/demand Printer Extensions and Notifications
ProfSvc running/auto User Profile Service
QWAVE stopped/demand Quality Windows Audio Video Experience
RasAuto stopped/demand Remote Access Auto Connection Manager
RasMan stopped/demand Remote Access Connection Manager
RemoteAccess stopped/disabled Routing and Remote Access
RemoteRegistry stopped/auto Remote Registry
RmSvc stopped/demand Radio Management Service
RpcEptMapper running/auto RPC Endpoint Mapper
RpcLocator stopped/demand Remote Procedure Call (RPC) Locator
RpcSs running/auto Remote Procedure Call (RPC)
RSoPProv stopped/demand Resultant Set of Policy Provider
sacsvr stopped/demand Special Administration Console Helper
SamSs running/auto Security Accounts Manager
SCardSvr stopped/disabled Smart Card
ScDeviceEnum running/demand Smart Card Device Enumeration Service
Schedule running/auto Task Scheduler
SCPolicySvc stopped/demand Smart Card Removal Policy
seclogon running/demand Secondary Logon
SENS running/auto System Event Notification Service
SensorDataService stopped/demand Sensor Data Service
SensorService running/demand Sensor Service
SensrSvc stopped/demand Sensor Monitoring Service
SessionEnv running/demand Remote Desktop Configuration
SharedAccess stopped/demand Internet Connection Sharing (ICS)
ShellHWDetection running/auto Shell Hardware Detection
smphost stopped/demand Microsoft Storage Spaces SMP
SNMPTRAP stopped/demand SNMP Trap
SolarWinds_TFTP_Server running/auto SolarWinds TFTP Server
Spooler running/auto Print Spooler
sppsvc stopped/auto Software Protection
SSDPSRV running/demand SSDP Discovery
SstpSvc stopped/demand Secure Socket Tunneling Protocol Service
StateRepository running/demand State Repository Service
stisvc stopped/auto Windows Image Acquisition (WIA)
StorSvc running/demand Storage Service
svsvc stopped/demand Spot Verifier
swprv stopped/demand Microsoft Software Shadow Copy Provider
SysMain stopped/demand Superfetch
SystemEventsBroker running/auto System Events Broker
TabletInputService running/demand Touch Keyboard and Handwriting Panel Service
TapiSrv stopped/demand Telephony
TermService running/demand Remote Desktop Services
Themes running/auto Themes
TieringEngineService stopped/demand Storage Tiers Management
tiledatamodelsvc running/auto Tile Data model server
TimeBrokerSvc running/demand Time Broker
TrkWks running/auto Distributed Link Tracking Client
TrustedInstaller stopped/demand Windows Modules Installer
tzautoupdate stopped/demand Auto Time Zone Updater
UALSVC running/auto User Access Logging Service
UevAgentService stopped/disabled User Experience Virtualization Service
UI0Detect stopped/demand Interactive Services Detection
UmRdpService running/demand Remote Desktop Services UserMode Port Redirector
upnphost stopped/demand UPnP Device Host
UserManager running/auto User Manager
UsoSvc stopped/demand Update Orchestrator Service for Windows Update
VaultSvc running/demand Credential Manager
vds stopped/demand Virtual Disk
VGAuthService running/auto VMware Alias Manager and Ticket Service
VM3DService running/auto VMware SVGA Helper Service
vmicguestinterface stopped/demand Hyper-V Guest Service Interface
vmicheartbeat stopped/demand Hyper-V Heartbeat Service
vmickvpexchange stopped/demand Hyper-V Data Exchange Service
vmicrdv stopped/demand Hyper-V Remote Desktop Virtualization Service
vmicshutdown stopped/demand Hyper-V Guest Shutdown Service
vmictimesync stopped/demand Hyper-V Time Synchronization Service
vmicvmsession stopped/demand Hyper-V PowerShell Direct Service
vmicvss stopped/demand Hyper-V Volume Shadow Copy Requestor
VMTools running/auto VMware Tools
vmvss stopped/disabled VMware Snapshot Provider
vmware-converter-agent running/auto VMware vCenter Converter Standalone Agent
vmware-converter-server running/auto VMware vCenter Converter Standalone Server
vmware-converter-worker running/auto VMware vCenter Converter Standalone Worker
VMwareCAFCommAmqpListener stopped/demand VMware CAF AMQP Communication Service
VMwareCAFManagementAgentHost stopped/demand VMware CAF Management Agent Service
VSS stopped/demand Volume Shadow Copy
W32Time running/auto Windows Time
WalletService stopped/demand WalletService
WbioSrvc stopped/auto Windows Biometric Service
Wcmsvc running/auto Windows Connection Manager
WdiServiceHost running/demand Diagnostic Service Host
WdiSystemHost stopped/demand Diagnostic System Host
Wecsvc stopped/demand Windows Event Collector
WEPHOSTSVC stopped/demand Windows Encryption Provider Host Service
wercplsupport stopped/demand Problem Reports and Solutions Control Panel Support
WerSvc stopped/demand Windows Error Reporting Service
WiaRpc stopped/demand Still Image Acquisition Events
WinHttpAutoProxySvc running/demand WinHTTP Web Proxy Auto-Discovery Service
Winmgmt running/auto Windows Management Instrumentation
WinRM running/auto Windows Remote Management (WS-Management)
wisvc stopped/demand Windows Insider Service
wlidsvc stopped/demand Microsoft Account Sign-in Assistant
wmiApSrv stopped/demand WMI Performance Adapter
WPDBusEnum stopped/demand Portable Device Enumerator Service
WpnService running/auto Windows Push Notifications System Service
WSearch stopped/disabled Windows Search
wuauserv stopped/demand Windows Update
wudfsvc running/demand Windows Driver Foundation - User-mode Driver Framework
XblAuthManager stopped/demand Xbox Live Auth Manager
XblGameSave stopped/demand Xbox Live Game Save
CDPUserSvc_934af running/auto CDPUserSvc_934af
OneSyncSvc_934af running/auto Sync Host_934af
PimIndexMaintenanceSvc_934af running/demand Contact Data_934af
UnistoreSvc_934af running/demand User Data Storage_934af
UserDataSvc_934af running/demand User Data Access_934af
WpnUserService_934af stopped/demand Windows Push Notifications User Service_934af
CDPUserSvc_420bde6 running/auto CDPUserSvc_420bde6
OneSyncSvc_420bde6 running/auto Sync Host_420bde6
PimIndexMaintenanceSvc_420bde6 stopped/demand Contact Data_420bde6
UnistoreSvc_420bde6 stopped/demand User Data Storage_420bde6
UserDataSvc_420bde6 stopped/demand User Data Access_420bde6
WpnUserService_420bde6 stopped/demand Windows Push Notifications User Service_420bde6
CWAUpdaterService running/auto Citrix Workspace Updater Service
CDPUserSvc_2f30aa81 running/auto CDPUserSvc_2f30aa81
OneSyncSvc_2f30aa81 running/auto Sync Host_2f30aa81
PimIndexMaintenanceSvc_2f30aa81 stopped/demand Contact Data_2f30aa81
UnistoreSvc_2f30aa81 stopped/demand User Data Storage_2f30aa81
UserDataSvc_2f30aa81 stopped/demand User Data Access_2f30aa81
WpnUserService_2f30aa81 stopped/demand Windows Push Notifications User Service_2f30aa81
CDPUserSvc_309e0367 running/auto CDPUserSvc_309e0367
OneSyncSvc_309e0367 running/auto Sync Host_309e0367
PimIndexMaintenanceSvc_309e0367 stopped/demand Contact Data_309e0367
UnistoreSvc_309e0367 stopped/demand User Data Storage_309e0367
UserDataSvc_309e0367 stopped/demand User Data Access_309e0367
WpnUserService_309e0367 stopped/demand Windows Push Notifications User Service_309e0367
nxlog running/auto nxlog
CSFalconService running/auto CrowdStrike Falcon Sensor Service
CDPUserSvc_569d6383 running/auto CDPUserSvc_569d6383
OneSyncSvc_569d6383 running/auto Sync Host_569d6383
PimIndexMaintenanceSvc_569d6383 stopped/demand Contact Data_569d6383
UnistoreSvc_569d6383 stopped/demand User Data Storage_569d6383
UserDataSvc_569d6383 stopped/demand User Data Access_569d6383
WpnUserService_569d6383 stopped/demand Windows Push Notifications User Service_569d6383
CheckmkService running/auto Checkmk Service
<<<dotnet_clrmemory:sep(124)>>>
AllocatedBytesPersec|Caption|Description|FinalizationSurvivors|Frequency_Object|Frequency_PerfTime|Frequency_Sys100NS|Gen0heapsize|Gen0PromotedBytesPerSec|Gen1heapsize|Gen1PromotedBytesPerSec|Gen2heapsize|LargeObjectHeapsize|Name|NumberBytesinallHeaps|NumberGCHandles|NumberGen0Collections|NumberGen1Collections|NumberGen2Collections|NumberInducedGC|NumberofPinnedObjects|NumberofSinkBlocksinuse|NumberTotalcommittedBytes|NumberTotalreservedBytes|PercentTimeinGC|PercentTimeinGC_Base|ProcessID|PromotedFinalizationMemoryfromGen0|PromotedMemoryfromGen0|PromotedMemoryfromGen1|Timestamp_Object|Timestamp_PerfTime|Timestamp_Sys100NS|WMIStatus
4320483696|||8297|0|2240829|10000000|56623800|9117796|20370216|7627276|75215368|9830744|_Global_|105416328|6896|4818495|4818365|4818345|4818339|365|583|140341248|1073659904|77610384|4294967295|0|1957408|9117796|7627276|0|13057444454138|133060346214390000|OK
12074092|||988|0|2240829|10000000|6291456|1386852|1396776|688592|688628|797640|SelfService|2883044|1862|2|1|0|0|116|87|6815744|33546240|593|693262793|11756|37364|1386852|688592|0|13057444454138|133060346214390000|OK
0|||0|0|2240829|10000000|0|0|0|0|0|0|SelfServicePlugin|0|0|0|0|0|0|0|38|0|0|0|0|0|0|0|0|0|13057444454138|133060346214390000|OK
0|||0|0|2240829|10000000|0|0|0|0|0|0|Receiver|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|13057444454138|133060346214390000|OK
0|||0|0|2240829|10000000|0|0|0|0|0|0|concentr|0|0|0|0|0|0|0|6|0|0|0|0|0|0|0|0|0|13057444454138|133060346214390000|OK
81713272|||421|0|2240829|10000000|6291456|2785520|6291496|6903336|37279592|3252936|dllhost|46824024|67|11|5|1|0|0|5|46845952|402644992|67882|358233|14640|21416|2785520|6903336|0|13057444454138|133060346214390000|OK
2479660|||184|0|2240829|10000000|5242880|173200|231308|0|12|412528|CitrixReceiverUpdater|643848|273|2|0|0|0|0|20|1662976|33546240|87|777284111|7224|17354|173200|0|0|13057444454138|133060346214390000|OK
90998900|||2183|0|2240829|10000000|5242884|109092|346992|0|2083092|727400|SelfService#1|3157484|2200|33|5|1|0|115|142|6811648|33546240|123|2048160290|9076|59264|109092|0|0|13057444454138|133060346214390000|OK
81708080|||439|0|2240829|10000000|6291456|2769184|9842024|0|30254216|3252936|dllhost#1|43349176|65|11|4|1|0|0|5|46858240|402644992|42900|367700|728|22280|2769184|0|0|13057444454138|133060346214390000|OK
0|||0|0|2240829|10000000|0|0|0|0|0|0|SelfServicePlugin#1|0|0|0|0|0|0|0|39|0|0|0|0|0|0|0|0|0|13057444454138|133060346214390000|OK
10521368|||0|0|2240829|10000000|5242880|72|5440|0|12|17752|Receiver#1|23204|88|2|0|0|0|0|0|5382144|33546240|0|105367162|3896|0|72|0|0|13057444454138|133060346214390000|OK
0|||0|0|2240829|10000000|0|0|0|0|0|0|concentr#1|0|0|0|0|0|0|0|6|0|0|0|0|0|0|0|0|0|13057444454138|133060346214390000|OK
98058844|||2205|0|2240829|10000000|5242884|90248|193640|0|1848896|680200|SelfService#2|2722736|1914|37|3|2|0|114|133|6766592|33546240|186|1985938784|14832|66712|90248|0|0|13057444454138|133060346214390000|OK
0|||0|0|2240829|10000000|0|0|0|0|0|0|SelfServicePlugin#2|0|0|0|0|0|0|0|38|0|0|0|0|0|0|0|0|0|13057444454138|133060346214390000|OK
10521368|||0|0|2240829|10000000|5242880|72|5440|0|12|17752|Receiver#2|23204|90|2|0|0|0|0|0|5382144|33546240|0|105367117|6576|0|72|0|0|13057444454138|133060346214390000|OK
0|||0|0|2240829|10000000|0|0|0|0|0|0|concentr#2|0|0|0|0|0|0|0|6|0|0|0|0|0|0|0|0|0|13057444454138|133060346214390000|OK
23129732|||1876|0|2240829|10000000|6291456|1802872|1821100|35348|377272|630232|UpdaterService|2828604|121|4|3|1|0|1|48|8040448|33546240|1|94534978|6296|1732970|1802872|35348|0|13057444454138|133060346214390000|OK
1749036532|||1|0|2240829|10000000|5243568|684|236000|0|2683636|41368|SolarWinds TFTP Server|2961004|216|4818391|4818344|4818339|4818339|19|10|5775360|33546240|2360572|2296796122|2180|48|684|0|0|13057444454138|133060346214390000|OK
<<<ps:sep(9)>>>
(SYSTEM,64,4,0,0,0,0,230618012968750,0,4,5827118) System Idle Process
(SYSTEM,3464,140,0,4,0,0,195580625000,2270,178,5827118) System
(SYSTEM,2147490148,1312,0,368,0,312500,17343750,66,2,5827118) smss.exe
(SYSTEM,2147538388,5120,0,532,2,70312500,910937500,462,12,5827115) csrss.exe
(SYSTEM,2147530980,5768,0,632,1,468750,1562500,119,1,5827114) wininit.exe
(SYSTEM,2147528032,13328,0,768,7,4028281250,29710781250,380,5,5827114) services.exe
(\\NT AUTHORITY\SYSTEM,2147567512,37064,0,784,22,10725312500,7196250000,2694,11,5827114) lsass.exe
(\\NT AUTHORITY\SYSTEM,2147611208,33684,0,880,18,18047656250,127558906250,2062,18,5827113) svchost.exe

<<<>>>
<<<robotmk:sep(0)>>>
{
"runner": {
"encoding": "zlib_codec",
"robotmk_version": "v1.2.10-beta-1",
"id": "runner",
"execution_mode": "agent_serial",
"start_time": "2022-08-27T00:43:18.452495+10:00",
"end_time": "2022-08-27T00:43:18.529493+10:00",
"assigned_host": [
"support01.domain.com",
"support01"
],
"runtime_total": 0.076998,
"runtime_suites": 0.071999,
"runtime_robotmk": 0.0049990000000000034,
"selective_run": false,
"cache_time": 120,
"execution_interval": 60,
"is_piggyback_result": false
},
"suites": [
{
"id": "hello_world",
"cache_time": 120,
"execution_interval": 60,
"path": "hello_world",
"tag": null,
"start_time": "2022-08-27T00:43:18.456495+10:00",
"htmllog": null,
"xml": "eNqtk01vGjEQhu/5FVNfaA/sFyQgtN6IpodW6gElkXJZqXJ2zWKt10b2bCj/vrYhhDYVRagnj8cz7zMej/Pbn52EF26s0IoO0igZAFeVroVq6KDH5XRwW1zlRj9rhIYrbhhqQ8l9cFxHSZTCx8UWV1rBKEqT6AactRFqlH0irwm8piRLsiyZZhNIktl4NEun0XiSEjBrRsmSScsJ2GrFO/ZaCxkRB7a9QA7CCVgXrVjHKfnKpdTwpI2sXZLuTeWcd7NyYXRjWPeFISudVNV2bclcCViG8suVz/uxCXl/SA//q/qxHYVTz0Nu8Q03xAPx0R/gisOuNJBC8f31280+5rtu4FHDnVZWS+5jng0zW0o+90LiN+WDmWmKo+phaXQH4aG6FuYVq3m3/ZDHPuwqr3VVOFEbwI144Qo6bq27EaAOzmrHivLYx7p+IcPewm6hZDF/eCB+ZxCFL/H9C18nN8RNU33yPHbScbu5EDA+E+CbfyEiOxMR5ukixnhyCUNYFJX1g6WRyb0T1sw6qJutJROSksShW7H2RjGXEvysWafjQkNb9qnImrANyzHkhN6JX3k8hgfYeXLDfytGf1M/tCb+rTfcGG28Eb9Z4UcWvwD5xIuL",
"end_time": "2022-08-27T00:43:18.528494+10:00",
"attempts": 1,
"max_executions": 1,
"rc": 0,
"status": "nonfatal"
}
]
}

Hello World from Robotmk Academy!

<<<>>>
<<<systemtime>>>
1661525022

its strange as i can run the tests manually no issues and can see the tests being created every 5 min in log directory

Any help would be appreciated i feel like i am close.

1 Like

Hi :wave:

Look at the very end of the agent output:

It seems that you tried to execute one of the functional tests with Robotmk.
Those tests are not meant to be integrated into Checkmk because they are writing a “Hello World” to the console (keyword: Log To Console).
robotmk-runner.py is meant to be a “silent” plugin, which executes RF and stores the result files. robotmk.py is the one who collects these files and generates the agent output.

Rule of thumb: avoid to write any Output on STDOUT during a RF test.

Quick fix to make your setup work: just replace “Log To Console” by “Log”.
This keyword only logs into the RF log file and no output is written to stdout.

Best regards,
Simon

1 Like

lol!
Simon thank you very much for response and explanation. What an awesome extension you have developed.

Thanks Simon, it worked here. It would be great to share some test case to help in the first deployment part. I was facing the same problem as “thedom” because I couldn’t find a test case in the blog post, only the screenshot of it.

You’re absolutely right, there’s still a lot of room for improvement.
As long as there is no official documentation, it is almost impossible to keep all written articles, blogposts etc. up to date. That eats up too much time.
But let me know here if you are facing any problems. I am happy to help!

2 Likes

Hello.

I’m running into a similar issue as this one.
I’m setting up the tests on a Linux Ubuntu machine, and I believe I’ve successfully installed the agent with the Robotmk plugin. In the folder “/usr/lib/check_mk_agent/plugins” I have the “robotmk-runner.py” file.
I was also able to test the Robot Framework and it runs tests successfully by hand on the console.

So first, I don’t know where to put the test files. All articles that mention this folder (which is “robot”) are run on Windows and the structure is not the same in Linux. I’m not sure if it should also use the “robot” folder, but this folder is not created initially anywhere. I have two different folders called “check_mk_agent” in different paths and tried to create the “robot” folder in one of them, and placed the test files in there. But it doesn’t seem to be running anything.
Placed it at “/usr/lib/check_mk_agent/”.
The other possible folder is "/var/lib/check_mk_agent/

As you can see below, I get the error message on the Checkmk monitoring for this agent, and not on the test run logs as I don’t have any (maybe this is the reason for the error).

jtc@ubuntu-client:~$ robot --version
Robot Framework 6.0.1 (Python 3.10.6 on linux)
jtc@ubuntu-client:~$ cmk-agent-ctl --version
cmk-agent-ctl 2.1.0p15

Can anyone shed some light? Or point to a document that shows how to set it up in Linux?

Thank you.

Hello.

I’ve attempted to install also on a Windows machine that I added to Checkmk by installing the agent with the Robotmk plugin. The same happens. Maybe I’m misconfiguring the agent?
I can see that I have the files:
C:\ProgramData\checkmk\agent\config\robotmk.yml
C:\ProgramData\checkmk\agent\plugins\robotmk.py

The file robotmk.yml contents are:

# Created by Check_MK Agent Bakery.
# This file is managed via WATO, do not edit manually or you
# lose your changes next time when you update the agent.

# This file is part of Robotmk, a module for the integration of Robot
# framework test results into Checkmk.
#
# https://robotmk.org
# https://github.com/elabit/robotmk
# https://robotframework.org/
# ROBOTMK VERSION: v1.4.1

global:
  execution_mode: agent_serial
  agent_output_encoding: zlib_codec
  transmit_html: false
  log_level: INFO
  log_rotation: 7
  cache_time: 960
  execution_interval: 900
suites: {}

Comparing to your example on a blog post, my file is missing a lot of entries, like the robotdir: C:\ProgramData\checkmk\agent\robot, and in fact, I don’t have this robot folder. So I seem to have the same issue both on Windows and Linux.
Below is my config. Am I missing something?


Thank you.

Add the robotmk suite/test path like below to your agent rule:

bake the agent and redeploy

Make sure you have the robot file and directory as per the suite/test path per your rule/agent

Restart the service and then check immediately the below log folder

Hi Joel,
sorry for my late reply. Has been a busy week…
The blogpost is a bit outdated. That’s why your robotmk.yml looks different from the one in the article.
As long as there is no documentation for Robotmk (yet), I can highly recommend the inline help. I think most of your questions are answered there already:

In order to better understand what Robotmk does (and what not…), inspect the log files:
image

Yes, the robotdir must be created by hand.

Then, regarding your robotmk.yml: it contains suites: {}. This is ok - Robotmk will execute all suites found in robotdir. But without specifying suite names, you cannot benefit from the Robotmk feature to set Robot Parameters like variables, re-execution etc.

Also check the following things and let me know:

  • Can you execute the Robot test itself? => robot foo.robot
  • Is the CMK agent able to start robotmk-runner.py?
    • On Windows, Python modules must be installed within an admin cmd (pip3 install robotframework pyyaml mergedeep python-dateutil) - there should never be Python modules in a profile directory
    • Check the cmk agent log: which interpreter does the cmk agent use to start robotmk-runner? If you see the interpreter of the agent (venv…), this is wrong. In this case, configure the Python interpreter like this:
      image
  • Does your Robot test produce any console output? The runner execution (see above) must not produce any stdout.
  • Check the log files robotmk-controller.log and robotmk-runner.log for any error (increase the logging level in robotmk.yml)
  • Does the runner produce State files? XML/HTML files?
  • Execute the agent:
    • Does it produce a <<<robotmk>>> section when executed locally?
    • Do you see the section if executed remotely from the CMK server?

I am happy to help you - kind regards,
Simon

@JoelC Let me know if this was of any help for you.
Regards,
Simon

Hello.

Thank you @thedom and @simonm for the help.
Sorry for the late reply but got some other important issue to attend to.

  • I’ve created a folder for the test inside the robot folder that I also created. Moved the .robot file there.
  • Configured a new suite for this test. But I think it was not necessary as for testing purposes, the robotmk would run the tests existing on the robot folder, and it didn’t.
  • Baked a new agent and deployed. Restarted agent on the machine.
  • I don’t have the log\robotmk folder. It still doesn’t seem to be working. I have no robotmk logs anywhere.
  • I’m able to run the test manually with the ‘robot’ command. It works. I’ve removed from the test the output part (I’m using hello-world), as I read somewhere that it would be an issue.
  • Is this what you asked about the interpreter? This line from the log, looks like “venv” in there:
    2022-11-22 17:57:35.579 [srv 4828] [Trace] Exec app ‘C:\ProgramData\checkmk\agent\modules\python-3.venv\Scripts\python.exe C:\ProgramData\checkmk\agent\plugins\robotmk-runner.py’, mode [0]
  • I didn’t had a python rule so I added one as per your suggestion.
  • I seem to have python installed under my user profile. It was already there as the Windows machine I’m using for the test is my laptop and python was already installed for other needs. I don’t want to mess with it as I use it for some of my work tasks. If it must not be there, then I’ll have to revert to the Linux test box that has this same issue and continue the tests there.
  • I didn’t spot any XML/HTML files, except when I run manually the test.
  • I executed the agent exe by hand and the output is a set of different instructions for different uses, but no reference to robotmk was found.
  • Don’t know how to execute it from the server. Is it from the monitoring site, somewhere?

Sorry for the trouble, and thank you for the help.

Hi Joel,

ok, your agent cannot execute the robotmk scripts for some reason.

As long as you see a line like

Exec app ‘C:\ProgramData\checkmk\agent\modules\python-3.venv\Scripts\python.exe C:\ProgramData\checkmk\agent\plugins\robotmk-runner.py’,

robotmk will never run properly. The CMK Python does not have the required modules.

You wrote that you created the rule to disable the CMK Python. => What’s now in the agent log?
You should see now the OS Python executing robotmk. This is the next step you need to take. (It’s obvious that without a successful start of robotmk no HTML/XML can be generated)

Of course, it is possible to also have a Python in the user profile.
But if the Checkmk agent should run robotmk, the one and only place where the modules should be is in the OS python “site-packages”.
Unfortunately, opening an Admin cmd.exe and installing the modules will report that they are already installed - even if you installed them first in your user profile by accident. The user python is within of the module search path.

For testing, you could rename your user installation of Python to something like python_ so that there isn’t any module to load from this place anymore.

Another approach is to open an admin cmd and execute

psexec -i -s cmd.exe 

PSexec

This opens a cmd with SYSTEM context, that means: exactly the user the CMK agent is running with.
Everything you can start here, is able to be started by the CMK agent, too.

Hope that helps!
regards,
Simon

Ping @JoelC - did this help?