Check-mk-free-2.0.0p24 depends on libperl5.32; however: Package libperl5.32 is not installed

CMK version: check-mk-free-2.0.0p24
OS version: Ubuntu 21.04 LTS

Error message:
Selecting previously unselected package check-mk-free-2.0.0p24.
(Reading database … 77834 files and directories currently installed.)
Preparing to unpack check-mk-free-2.0.0p24_0.hirsute_amd64.deb …
Unpacking check-mk-free-2.0.0p24 (0.hirsute) …
dpkg: dependency problems prevent configuration of check-mk-free-2.0.0p24:
check-mk-free-2.0.0p24 depends on libperl5.32; however:
Package libperl5.32 is not installed.

dpkg: error processing package check-mk-free-2.0.0p24 (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
check-mk-free-2.0.0p24

Output of “cmk --debug -vvn hostname”: (If it is a problem with checks or plugins)

Getting the same error while trying to install it on Ubuntu 20.04 LTS.

Is it really the same error message on 20.04?
The 20.04 package has libperl5.30 as dependency.
On my 20.04 systems i get no such error. Please keep in mind that 21.04 is not supported from Ubuntu side anymore.

Hi,
how do you install the package? What’s the command?

Karl

sudo apt install ./check-mk-free-2.0.0p24_0.hirsute_amd64

That’s the command I used.

Thanks for sharing this, I created a fresh Ubuntu 20.04 LTS and it works without any error for me. My bad i tried on other machines with Ubuntu 20.04 LTS and it didn’t work and throw the same error. So under the impression that there is something wrong with the package…

I had this problem with wrong checkmk installation packages for the ubuntu releases. Should work if you ve downloaded the correct package for your release.