Checking internet connection does not work as described

Hi,

I followed these instructions to check internet connection:

I set up a host with 2 IP addresses:

Those 2 IP addresses are from Root-Nameserver – Wikipedia so I assume they will be always available. ICMP works on them

The checked worked for couple of minutes an then suddenly the status went down

Both IP addressses are working fine and respond to icmp when checked via manual ping

Any idea what is going wrong?

PLEASE can anyone let me insert more than 1 picture in one post?

PLEASE can anyone let me insert more than 1 picture in one post?

12

PLEASE can anyone let me insert more than 1 picture in one post?

The most important thing is missing. How does your defined ping service looks like?
If there is a problem you should see it inside the ping.

“Check host with ping” as shown in the above screenshot is not sufficient?

Hi,
which release and version of Checkmk do you use? Open Source or Enterprise? Patch-Level?

Karl

The output of your ping check is relevant not the definition of the service.

1 Like

I am using the Raw Edition

OMD - Open Monitoring Distribution Version 2.0.0p15.cre

@ andreas-doehler

How do I check this?

13

Saying something about not able to resolve name. What needs to be resolved? This is confusing me

You see something on your ping check is wrong. It is in unknown state and complains about some variable it cannot resolve. If you click on this check you will see at the bottom the complete command line with all arguments.

It is showing this

Service check command check_mk_active-icmp!-m 1 -w 200.00,80% -c 500.00,100% $HOST_ADDRESSES_4$ $HOST_ADDRESS_4$

Any further help would be appriciated

Hi,
there has been a bug in the Raw Edition when pinging multiple hosts. I thought that the bug has been fixed already?!?
https://checkmk.com/werk/12897

Karl

1 Like

Hi,

I removed additional IP addresses but error persists.

Hi,
that looks like a bug in the Raw edition (I get the same error with your settings). Your settings work fine in the Enterprise Edition.

Karl

Hi,
your problem should be fixed with werk 13519: https://checkmk.com/werk/13519

Karl